SOLVED Cannot change temperatures while printing



  • It looks like the temperatures cannot be changed for the bed/heater while the print is running via the web interface. I've tried adjusting the values in the tool area, as well as sending M104 commands to no avail. It's relatively inconvenient to not be able to adjust on-the-fly, am I missing something or is the feature still under construction?



  • I have no issues changing temps during a print...running a duet wifi v1.04 board with 2.03 (RTOS) firmware. You're missing a lot of information in your post...what hardware, firmware, etc....



  • Sorry, that was a terribly disorganized post, I'll be more clear in the future. I'm running a Duet3 v0.6 with firmware 3.0alpha 2019-09-05b2 with DWC 2.0.0-RC8-b3


  • administrators

    There was an issue in earlier DSF versions that caused exactly this kind of problem. If you are printing from a RaspPi, perform a system upgrade (connect to your RaspPi via PuTTY, login with pi (user) and raspberry (password) and run "sudo apt-get update && sudo apt-get upgrade"). You may want to do this in regular intervals, too.



  • Thanks for the response. I tried those commands on the pi but am still unable to control the temperature through DWC.


  • administrators

    AFAIR this problem was caused by RepRapFirmware so you may have to run M997 once to update it. Before you do so, please make sure you are really on DSF 1.0.4.1 by running M122 in the G-code console.



  • Here is the output from M122, it looks like I am running Duet Control Server v1.0.4.1. Are there any other required files before running M997?

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 3 v0.6 version 3.0alpha running on Duet 3 version v0.6
    Board ID: 08DGM-9T66A-G63SJ-6J9D4-3SD6Q-1U0BA
    Used output buffers: 1 of 32 (6 max)
    === RTOS ===
    Static ram: 67772
    Dynamic ram: 155984 of which 0 recycled
    Exception stack ram used: 576
    Never used ram: 168884
    Tasks: NETWORK(ready,1980) HEAT(blocked,1208) CanReceiv(suspended,3804) CanSender(suspended,1496) CanClock(blocked,1432) TMC(blocked,592) MAIN(running,3768) IDLE(ready,156)
    Owned mutexes:
    === Platform ===
    Last reset 01:20:37 ago, cause: software
    Last software reset at 2019-09-30 17:33, reason: Unknown, spinning module Platform, available RAM 168880 bytes (slot 1)
    Software reset code 0x0010 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0442b000 BFAR 0x00000000 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 25.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 43.9, current 46.9, max 47.4
    Supply voltage: min 23.7, current 23.8, max 24.2, under voltage events: 0, over voltage events: 0, power good: yes
    12V rail voltage: min 12.1, current 12.2, max 12.3, under voltage events: 0
    Driver 0: standstill, reads 46171, writes 23 timeouts 0, SG min/max 0/298
    Driver 1: standstill, reads 46172, writes 23 timeouts 0, SG min/max 0/163
    Driver 2: standstill, reads 46173, writes 23 timeouts 0, SG min/max 0/178
    Driver 3: standstill, reads 46183, writes 14 timeouts 0, SG min/max 0/0
    Driver 4: standstill, reads 46175, writes 23 timeouts 0, SG min/max 0/163
    Driver 5: standstill, reads 46189, writes 11 timeouts 0, SG min/max 0/0
    Date/time: 2019-09-30 18:54:36
    Slowest loop: 313.00ms; fastest: 0.30ms
    === Move ===
    Hiccups: 1107, FreeDm: 375, MinFreeDm: 371, MaxWait: 3532708ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 7, completed moves: 7, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http* is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon* is ready with "M122" in state(s) 0
    queue is idle in state(s) 0
    lcd is idle in state(s) 0
    spi is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 89.31ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8
    - Ethernet -
    State: 2
    Socket states: 0 0 0 0 0 0 0 0
    === Linux interface ===
    State: 1, failed transfers: 0
    Last transfer: 101ms ago
    RX/TX seq numbers: 24940/20025
    SPI underruns 0, overruns 0
    Number of disconnects: 1
    Buffer RX/TX: 0/0-0
    === Duet Control Server ===
    Duet Control Server v1.0.4.1
    Code buffer space: 2048
    Configured SPI speed: 2000000 Hz
    Full transfers per second: 35.96
    


  • but you are running an earlier version of the Duet firmware suggest you upgrade that to V3.0B10

    Firmware



  • Upgrading all of the firmware/softwares resolved the issue. Thank you all for the help!


Log in to reply