Ethernet connectivity



  • I'm trying to enable ethernet. I hit command M552 S1, I receive 'ok' (the board does not reply with Network running). Am I missing a step? I'm connected to a live ethernet port.



  • Can you show us the network settings from your config file please?

    Can you ping the board from another machine connect4ed to the network?

    This is my network settings section:

    ; Network
    M550 POldSteel
    M540 PBE:EF:DE:AD:FE:DD
    M552 P192.168.82.114 S1
    M553 P255.255.255.0
    M554 P192.168.82.1
    M586 P0 S1                     ; Enable HTTP
    M586 P1 S0                     ; Disable FTP
    M586 P2 S0                     ; Disable Telnet
    


  • Hi DocTrucker, thanks for the speedy reply! could you advise how to get the config file up?

    These are the diagnostics:

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet Ethernet 1.02 or later
    Board ID: 08DGM-917DA-G4MSD-6JTD8-3SJ6T-K8TB8
    Used output buffers: 1 of 20 (1 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98492 of which 0 recycled
    Exception stack ram used: 312
    Never used ram: 6744
    Tasks: NETWORK(ready,1612) HEAT(blocked,848) MAIN(running,3780) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:10:04 ago, cause: power up
    Last software reset time unknown, reason: Unknown, spinning module Platform, available RAM 6396 bytes (slot 0)
    Software reset code 0x00b0 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f80f BFAR 0xe000ed38 SP 0x20004a8c Task 0x4e49414d
    Stack: 0044b913 00448886 6100f000 00000000 00000000 00000000 bff00000 3331bb4c 40000000 3f317200 b5ddea0e 388aa908 bb35fe81 00000000 00000000 3f800000 00000000 00000000 437a0000 20000010 0044bb0b 00000000 0044b913
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 23.5, current 31.9, max 32.1
    Supply voltage: min 0.8, current 24.2, max 24.3, under voltage events: 1, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 1374386276
    Slowest loop: 0.30ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 0.26ms; fastest: 0.02ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8
    Interface state 5, link 100Mbps full duplex



  • Good point, if you've not got ethernet connection you cant download from the duet web control! 😄

    Two options.

    • Shut down machine, remove sd card and read it from the sys folder.
    • Fire off the following commands to the gcode (one at a time!): M550, M540, M552, M553, M554, M586.

    It sounds like you haven't set up your config.g file yet?


  • Moderator

    There's a note on the setup page here: https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7#s20

    The Duet 2 Ethernet and Duet 2 Maestro come with a factory configured fixed address used during testing. This address will probably not work with your network and may cause conflicts. It is recommended to enable DHCP when using the RepRapFirmware configurator to generate your configuration file.

    Not sure if this is still the case. Try sending the following commands:
    M552 S0 : Turns off network, wait a few seconds
    M552 S1 P0.0.0.0 :Turns on network with DHCP enabled
    M586 P0 S1 ; Enable HTTP

    You should then be able to connect as in Step 9: https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7#s11
    Or use the ip address that turning the network back on should provide.

    You should then be able to get into the config.g and edit the network setup, ie the M552 line, to either DHCP or set a network address that works with your network.

    Ian



  • Thanks, this is super helpful!

    In the meantime, the board seems to have malfunctioned before I had a chance to send the commands and my terminal will no longer recognize it - might need to get a replacement!


  • Moderator

    Plenty of things to try before replacement: https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond

    Please run through that and let us know what does and does not work, especially LEDs on board, voltages, firmware, SD card corruption causing boot loop (so try removing SD card). If you have already wired your board up, could be something as simple as a short circuit in your wiring (endstops are a particular favourite).

    Ian



  • Hi droftarts,

    Thanks, I've run through the trouble shooting page: https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond

    Just to note, I have not connected anything (bar the power and ethernet to the board - was just trying to configure)

    When connected to my laptop, the board no longer powers on, the LEDs flash slowly and then turn off and I get a message on my computer saying:

    'The last USB device you connected to this computer malfunctioned and Windows does not recognise it'.

    I cannot find any coms port with the YAT terminal and my PC will not pick up the board - even when powered on normally.

    Do you think this warrants a replacement or is there something else I could try?



  • @heoconnor said in Ethernet connectivity:

    something else I could try?

    Do you see any power LEDs at all? or just the usb led flickering?
    if No; very quickly try a different USB cable, one you know charges a phone etc. this is a simple test that can avoid hours of weird and frustrating debug.
    USB cables are notorious for partially failing (you lose power, or data, but rarely both) and I've had a cable go bad on me in the middle of a debug session, wasting hours when all I needed to do was swap it out.

    Also: what happens if you use a wall-wart USB charger? does the board show power then?


  • Moderator

    Sounds like a short on the board somewhere, or a component has died, possibly the voltage regulator. Carefully check over the board for any stray metal filings, or anything else that could have bridged connections. As @EasyTarget says, try with a different USB lead, but note that some USB leads only provide power, so you won't be able to connect your PC to the Duet with one of these, even if it does power the board. Post a picture of both sides of your board so we can see if there's anything obvious failed or shorted.

    Ian



  • The same thing happened trying a different cable:

    The two red LEDs on either side of USB port flash and then go off, similarly a red and green LED, 3V+ and 3.3V flash and then die.

    I also tried using a standard usb charger - nothing turned on.

    screenshot of malfunction message.png

    IMG_3370.png.jpg

    IMG_3371.png.jpg

    IMG_3373.png.jpg


  • administrators

    I am assuming you have nothing connected to the Duet except USB and Ethernet. If you have other devices connected that are drawing power (e.g. a PanelDue) then it could just be that the USB supply you are using can't supply enough power.

    Try removing the SD card, it's not unknown for them to short the 3.3V supply out.

    • If the same happens (+5V and +3.3V LEDs on the Duet only flash briefly) -> warranty replacement
    • If the USB port appears and the 5V and 3.3V LEDs on the Duet remain on, then send M552 S1 via USB to turn on the Ethernet module. If the LEDs stay on and you get a message saying Ethernet is running, the problem is the SD card. We can send you a new one. If the LEDs then go off, the problem is the Ethernet module and it's a warranty replacement again.


  • @dc42 Yes, just USB and Ethernet were connected.

    I've tried removing the SD card and the same thing happens - As advised, I will return the board for a warranty replacement. Thanks for all your help!


Log in to reply