Maestro - Bed temperature reading is out by 15C



  • Is there any configuration needed around the bed temperature sensor to get it accurate? I've just wired up a Maestro and it's reporting the bed to be around 10C when the ambient temperature is 25C. I'll need to check hotter temps, but it was around 62C when set to 50C (if I remember correctly).



  • Most likely you are using the default settings for the thermistors, which can vary a lot from manufacturer to manufacturer. Can you post your config.g, and what thermistors/temperature sensors (manufacturer and part number, ideally) you are using?

    If you are sure you have set this up correctly, check your wiring, particularly any connections; any poor connections may increase resistance, and throw off the temperature reading.

    Ian



  • ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and
    M307 H0 A153.5 C555 D0.3 B0 ; Heatbed
    M307 H1 A278.6 C158.2 D3.8 S1.00 V24.2 B0

    ; set PWM limit
    ; Bed
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S80 ; Set temperature limit for heater 0 to 80C
    ; Hotend
    M305 P1 T100000 B4725 C7.060000e-8 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C


    The config was used previously with a Duet Wifi - bed temp reading was accurate with it.



  • Fixed by changing the bed settings to:
    ; Bed
    M305 P0 T100000 B4185 R2200 ; Set thermistor + ADC parameters for heater 0


Log in to reply