miniKossel will not home



  • I am on obtaining an error message --
    'Macro file homeall.g not found'
    -- when trying to home my mini Kossel delta printer.
    It looks like the homedelta.g macro file is not being loaded and so that the firmware thinks it is a Cartesion machine??
    The config.g macro file from the SD card is loading.
    This file does contain the M665 comand giving the delta geometry.
    The homedelta.g file is also in the sys directory on the SD card.
    It is my understanding that execution of M665 should result in the loading of the homedelta.g file?
    I do not understand why the software is trying to find a homeall.g file,which is not there and is not relevant to a delta machine.
    (N.B. also the X,Y and Z carriages cannot be moved individully as the software looks for homex.g etc files).
    What am I doing wrong??
    Any help most gratefully recieved.
    Thanks
    William


  • administrators

    homeall.g contains the instructions that tell the machine how to drive the axes to the endstops whereas M665 (in your config.g) defines delta parameters (see also https://duet3d.dozuki.com/Wiki/Gcode#Section_M665_Set_delta_configuration). It sounds like M665 is never executed in your config.g, hence the firmware remains in cartesian mode.

    If you are not familiar with the Duet, I suggest you start with a configuration bundle from https://configtool.reprapfirmware.org/Start


  • administrators

    If the firmware is looking for homeall.g instead of homedelta.g, that suggests that the M665 command has not been processed. Are you sure that config.g has been processed at all? Send M503 to check that it can be read.



  • Thanks for the reponse.
    M503 displays the config.g file, as does Settigns==> Configuration File.
    They show that the M665 etc are present and correct in the config.g file.

    I attach the printout from the M502 command
    [0_1570623492806_Result of M503.rtf](Uploading 100%)

    Result of M503.odt

    However, I still get the same error message when I try to home or move the carriages.

    Mysterious?

    William



  • i would strongly suggest that you create a new config with the configurator.
    there are several things missing in that config. i.e e steps configuration and thermistors.
    also the config is for a duet v0.8

    if you have bought the duet recently you have a duet2.


Log in to reply