Driver Issue on Windows 10 After Refresh



  • I've been using my Duet for over a year and love it. Yesterday, after refreshing Windows on my computer I have been unable to access the Duet via Yat or Pronterface etc after re-installing the Duet drivers. I can see the Duet, but get the error code "This Device Cannot Start. (Code 10)" I've attached an image of the error. I'm travelling so unfortunately can't switch to another computer at the moment. I wonder if others have dealt with this issue. I'm using a Windows Surface with only one USB port, but I have been able to use this setup in the past. I wonder if an updated Windows is the issue. code10.png



  • I've not seen that one before. I'd start with some basic windows device troubleshooting. Try removing the device entirely, rebooting, and rediscovering the device.



  • Thanks Phadrux,
    I'm back home now and to my relief the Duet board is just fine. It is indeed a Windows issue that might be somewhat specific to the particular Surface I'm using. I suspect the 1(!) USB port my surface has is somewhat damaged.

    At any rate, lesson learned, always have a plan B.

    I'll say this is solved, even though some Windows issue remains, but that would be for a Windows forum somewhere to solve.

    Now . . . back to printing as usual.


Log in to reply