NPN Inductive probe issues



  • Hi guys

    I'm having some weird issues setting up a NPN NO inductive probe.

    i've spent hours on it and i feel like i'm chasing my tail now.

    So i've set the probe up to act as an end stop as well and i can get that config working by homing and when it see's the object it stops so i know that is all good.

    I want to now level my bed and probe.. this is where i'm getting lost.
    I've followed the steps listed here on how to calibrate the trigger height
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe
    Which i think i've done correctly and added the below line into my config.g
    G31 P1000 Y35.0 Z0.96

    So i Save and reboot the machine and go to home the machine and i have a large gap on my Z axis and i notice the Z axis is reading 2mm in height - which i assume is from my Homeall file, ok so i drop my Z down the 2mm and it's now too tight too the bed and not where i had my calibration set - so i go through the steps again and reboot with the same results.
    What am i doing wrong?

    Here is part of my config.g
    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P5 F500 I1 T6000 A1 ; Probe Mode NPN NO P=Mode5 F=Speed it probes T=Move speed, Inverted Sig, A= test 1 times,
    G31 P1000 Y35.0 Z0.96
    M557 X10:310 Y30:340 S42.5 ; Define mesh grid

    Here is my Homeall.g:

    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-400 F6000 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 S1 Y-400 F6000
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-345 Y-375 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X180 Y210 F6000 ; move probe to bed center
    G30; probe the bed
    G1 X10 Y30 Z2 F6000 ; return to home position and 2mm higher than the surface

    Editing G31 P1000 Y35.0 Z0.96 in config.g doesn't seem to make any difference to see if i can get more gap when i move Z axis back to 0 it still touching the bed. e.g. G31 P1000 Y35.0 Z1.96 still yields the same result



  • go to this page after reboot and check that the settings have been applies

    https://duet3d.dozuki.com/Wiki/Duet_Web_Control_Manual#Section_Machine_Properties



  • Hi Veti

    It shows correct on that screen



  • What sort of bed are you probing onto? Material? how is it attached?
    Magnetic print surfaces and attachments corrupt the probe readings). If it wasn't for this I'd be using one of these probes myself.
    Also; it is considered a good idea to disable the bed heater (if you have one) while probing, the high currents flowing through conductors basically make yet another magnet, one that will switch on and off as the bed heater stabilises, not good for probe consistency.



  • EasyTarget,

    i'm printing onto a PEI coated aluminium bed from here https://clever3d.de/epages/7a4290fc-7c7f-46cc-9b99-eadef22228e2.sf/en_US/?ObjectPath=/Shops/7a4290fc-7c7f-46cc-9b99-eadef22228e2/Products/PEI-Pro3D-V-King

    i haven't tried to probe the bed without the heater on as i've always read to level a bed you should be at operating temperature?



  • @aceycv8 said in NPN Inductive probe issues:

    i haven't tried to probe the bed without the heater on as i've always read to level a bed you should be at operating temperature?

    You can simply disable the heater during the probe, either with macro commands or manually. I assume you are using the recommended 1Kw 110V AC heat mat?

    You are right in that you should probe at temperature if (like me) your bed shows expansion with temperature, but it wont cool down fast enough to distort the probe results if you simply disable the heat before the first probe move.

    I do not have any handy references, but this is a topic that has been covered elsewhere a number of times and the conclusion was that the changing/uneven magnetic fields from bed heaters can have quite a profound effect on some setups and inductive sensors.



  • Thanks EasyTarget

    i will try with no heater on the probe and see how it goes


  • administrators

    @aceycv8, part of the problem may be that by using P1000 in your G31 command you will get a slow response to the sensor. Try P100 instead.



  • Thanks Dc42 - i will make the config change and see


Log in to reply