Web control with Duet Ethernet



  • Following https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7 and have finished step 8.

    M552
    Network is enabled, configured IP address: 0.0.0.0, actual IP address: 10.137.148.106
    ok

    Following step 9, I enter the IP address into my browser but it won't load, am I missing something?


  • administrators

    I assume you are getting a failure to connect message, not a "Your Duet rejected the HTTP request" message.

    If you are running Windows on your PC, go to a command prompt, run ipconfig and post the output here.

    Also from a command prompt, run this:

    ping 10.137.148.106



  • Have you connected the Duet to your router, using an ethernet cable? Or is it plugged directly into your PC, using USB and ethernet?

    Ian



  • @droftarts it was connected directly to an ethernet cable from my lab and I was using a wifi connection on laptop. I thought this may be the issue so returning to this project this morning, I set up my laptop and the board using a router. No luck yet.

    @dc42 yes exactly, I was just getting a failure to connect message on my browser.

    Screenshot 2019-11-05 11.17.59.png



  • Really appreciate all the help so far!!

    also @dc42

    Screenshot 2019-11-05 12.12.37.png



  • @heoconnor Which Duet do you have, Duet 2 Ethernet or Duet 2 Maestro?

    How is the Duet getting the ip address 10.137.148.106? Is it set up DHCP? (By sending M552 S1, no 'P' parameter.) If so, it's on a different network from your Wifi network, as it is outside of the range of addresses that your PC's ipconfig reports, which should be 137.43.24.1 - 137.43.27.254. As this seems to be a large network, I'd advise against setting an ip address manually without consulting with your IT department; who knows what it might clash with!

    The Duet may also be having problems with your (I'm guessing corporate/university) network, for example new devices may not be allowed to connect to the network (check with your IT department), or it may be as simple as a non-working ethernet cable. Usually the ip address reports as 0.0.0.0 if the wire is disconnected, though; eg my Duet Maestro reports the following if ethernet is disconnected:

    SENDING:M552
    Network is enabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0
    

    You can set the Duet up directly connected to your PC; see my post here: https://forum.duet3d.com/topic/12552/issues-with-ender-3-and-duet-maestro/3

    I can't think of any advantage of putting a router between your PC and the Duet rather than wiring it directly. If you do, you will still need to set up ethernet on your laptop, and set up the router; the ipconfig response doesn't show an ethernet connection (would be under 'Ethernet adapter Ethernet') to a router, only the Wifi connection.

    Ian



  • uce.ie lets me believe that you are running is in a university environment.

    most likely what happens is that the dhcp server assigns unknown devices to a secure ip address.

    either have a talk with computing support. or set up your own network with your own router.



  • @droftarts it was an issue with the firewall of the university. I can finally see the webcontrol! Thanks a mill for all the help.

    Heather



  • @heoconnor said in Web control with Duet Ethernet:

    @droftarts it was an issue with the firewall of the university. I can finally see the webcontrol! Thanks a mill for all the help.

    Heather

    Great! It might still be worth connecting it directly to your laptop, or router just for your lab, as putting it on the university network does expose it to the rest of the university! And while you can set a password for access to the web interface, it's not very secure; see https://duet3d.dozuki.com/Wiki/Gcode#Section_M551_Set_Password

    Note that as this is sent in clear it does not (nor is it intended to) offer a security. But on machines that are (say) on a network, it might prevent idle messing about.

    Ian


Log in to reply