Sudden X homing problem, over homing when Y moves



  • Good afternoon, I'm sure this has been answered though buried!

    Everything has been working fine, I did upload a new generated config yesterday, but I hadn't adjust anything apart from fan speed - then today when I "home all", they home fine accept when the Y axis bed moves back to the centre, X starts moving past the home stop (at which point the belt is slipping) until Y stops moving. Individually they home fine and no problem in printing.

    Any suggestions?

    Thanks, James



  • When you generated the config.g, did you upload all the files from the config bundle, or just config.g? I'd expect you uploaded all of them, and some parameter has changed. If possible, can you compare the old and new homeall.g files? Or at least post the current one, and your config.g.

    Ian



  • Thanks Ian, I will check in the morning now as she's busy printing - good idea on comparing the two just in case I mucked up. Cheers

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.2 on Tue Nov 05 2019 20:56:44 GMT+0100 (Central European Standard Time)
    
    ; General preferences
    G90                                      ; send absolute coordinates...
    M83                                      ; ...but relative extruder moves
    M550 P"Duet2 Wifi"                       ; set printer name
    
    ; Network
    M552 S1                                  ; enable network
    M586 P0 S1                               ; enable HTTP
    M586 P1 S0                               ; disable FTP
    M586 P2 S0                               ; disable Telnet
    
    ; Drives
    M569 P0 S0                               ; physical drive 0 goes backwards
    M569 P1 S1                               ; physical drive 1 goes forwards
    M569 P2 S0                               ; physical drive 2 goes backwards
    M569 P3 S0                               ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3                         ; set drive mapping
    M350 X32 Y32 Z32 E16 I0                  ; configure microstepping without interpolation
    M92 X160.00 Y160.00 Z800.00 E837.00      ; set steps per mm
    M566 X240.00 Y120.00 Z12.00 E300.00      ; set maximum instantaneous speed changes (mm/min)
    M203 X12000.00 Y6000.00 Z180.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X390.00 Y390.00 Z20.00 E100000.00   ; set accelerations (mm/s^2)
    M906 X950 Y1500 Z950 E850 I30            ; set motor currents (mA) and motor idle factor in per cent
    M84 S5                                   ; Set idle timeout
    
    ; Axis Limits
    M208 X-20 Y0 Z0 S1                       ; set axis minima
    M208 X310 Y300 Z400 S0                   ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S0                            ; set active low and disabled endstops
    M574 Z1 S2                               ; set endstops controlled by probe
    
    ; Z-Probe
    M558 P2 H10 F120 T6000                   ; set Z probe type to modulated and the dive height + speeds
    G31 P500 X43 Y25 Z2.8                    ; set Z probe trigger value, offset and trigger height
    M557 X-5:245 Y265:195 S40                ; define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                         ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700              ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                             ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4388 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                             ; set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1                 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0.8 I0 F500 H1 T45              ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                         ; define tool 0
    G10 P0 X0 Y0 Z0                          ; set tool 0 axis offsets
    G10 P0 R0 S0                             ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings
    M558 p5 i0
    M557 X40:300 Y0:255 S40
    M572 D0 S0.05
    G29 S1
    
    
    ; Miscellaneous
    M501                                     ; load saved parameters from non-volatile memory
    
    
    


  • After investigating its caused by RRF Config Tool website and there latest update.

    homeall.g

    Since there latest update when you generate and download the config its omitting S2 in the Z homing causing it to grind the X axis.

    G1 S2 X-48 Y240 F6000   ; go to first bed probe point and home Z
    

    Since update:

    G1 X-48 Y240 F6000   ; go to first bed probe point and home Z 
    

    Which is a pain.



  • I'm speaking rubbish, but its something to do with the latest RRF website. When I use previous config zip its fine. If I extract, use custom config selecting the one unpacked, re-generate from the website its borked causing it to grind when homing Z as home all.

    Firmware Version: 	2.04 (2019-11-01b1)
    WiFi Server Version: 	1.21
    Web Interface Version: 	1.22.5
    

Log in to reply