need help to set Bed-Center and Origin 0,0 at the center



  • Hi

    i just trying for 2 days to get my new bed in the center and the origin on Center 0,0 everytime after homeall is not in the center.

    i have read this how to :
    https://duet3d.dozuki.com/Wiki/Centering_the_bed_or_setting_the_bed_origin

    i want to make 0,0 at bed center

    My bed is X=240 and Y =220
    Printable area is: X=230 and Y= 220

    thats my actual config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 11 2019 17:51:12 GMT+0200 (Mitteleuropäische Sommerzeit)
    
    ; General preferences
    G90                                      ; Send absolute coordinates...
    M83                                      ; ...but relative extruder moves
    
    ; Network
    M550 P"AM8"                              ; Set machine name
    M552 S1                                  ; Enable network
    M587 S"********************"  ; Configure access point. You can delete this line once connected
    M586 P0 S1                               ; Enable HTTP
    M586 P1 S0                               ; Disable FTP
    M586 P2 S0                               ; Disable Telnet
    
    ; Drives
    M569 P0 S0                               ; Drive 0 goes forwards X
    M569 P1 S0                               ; Drive 1 goes forwards Y
    M569 P2 S1                               ; Drive 2 goes backwards Z
    M569 P3 S1 				 ; Drive 3 goes forwards Extruder
    M569 P4 S1 			         ; Drive 4 2nd Z-motor - Normally used as Extruder 1
    
    ; Motor Remapping
    M584 X0 Y1 Z2:4 E3	; two Z motors connected to driver outputs Z and E1
    
    
    M350 X16 Y16 Z16 E16 I1               ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E392.40	; set steps per mm
    M566 X900.00 Y900.00 Z18.00 E120.00     ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z350.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z350.00 E250.00     ; set accelerations (mm/s^2)
    M906 X1400.00 Y1400.00 Z1400.00 E1120.00 I30            ; set motor currents (mA) and motor idle factor in per cent
    M84 S30  ; Set idle timeout                             ; Set idle timeout
    
    ; Axis Limits
    ;M671 X-17:205:205 Y105:205:15 P0.5   ; für manual bed levelling
    
    ;M671 X-17:100:215 Y190:-10:190 P0.5 ; adjusting screws at rear left (-15,190), front middle (100,-10) and rear right (215,190), thread pitch 0.5mm
    M671 X-36:230 Y0:0 S0.5 		 ; leadscrews at left and right of X axis für 2 motoren
    M208 X0 Y-14 Z0 S1                     ; set axis minima
    M208 X240 Y220 Z240 S0                  ; set axis maxima
    
    
    
    
    ; Endstops
    M574 X1 Y1 S0                            ; Set active low and disabled endstops
    
    ; Z-Probe
    M574 Z1 S2                               ; Set endstops controlled by probe
    M558 P5 I1 R0.4 F420			 ; Set Z probe type to effector and the dive height + speeds
    G31 X0 Y0 Z0  P100                      ; Set Z probe trigger value, offset and trigger height 
    M557 X15:223 Y5:223 S40                 ; define mesh grid
    ;M557 X15:223 Y5:210 P2                     ; 4 Punkte Bett Leveln
    
    
    ; Heaters
    ;M307 H0 B0 S1.00                         ; Disable bang-bang mode for the bed heater and set PWM limit
    ;M307 H0 A78.5, C355.9, D1.0	          ; Pid Tuining BED
    ;M143 H0 S130                             ; Set temperature limit for heater 0 to 130C
    
    M305 P0 T100000 B4138 R4700              ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                             ; Set temperature limit for heater 0 to 120C
    
    
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275                             ; Set temperature limit for heater 1 to 275C
    M307 H1 A224.6, C134.6, D5.3 S1		 ; Pid Tuning -nozzle
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                   ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                            ; Define tool 0
    G10 P0 X0 Y0 Z0                          ; Set tool 0 axis offsets
    G10 P0 R0 S0                             ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    
    ; Miscellaneous
    T0                                       ; Select first tool
    M501
    

    homeall:

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Thu Oct 03 2019 17:06:41 GMT+0200 (Mitteleuropäische Sommerzeit)
    G91                     ; relative positioning
    G1 Z5 F6000 S2          ; lift Z relative to current position
    G1 S1 X-258 Y-235 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000          ; go back a few mm
    G1 S1 X-258 Y-235 F360  ; move slowly to X and Y axis endstops once more (second pass)
    G90                     ; absolute positioning
    G1 X115 Y105 F6000        ; go to first bed probe point and home Z
    G30                     ; home Z by probing the bed
    
    ; Uncomment the following lines to lift Z after probing
    ;G91                    ; relative positioning
    ;G1 S2 Z5 F100          ; lift Z relative to current position
    ;G90                    ; absolute positioning
    

    home x :

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Thu Oct 03 2019 16:43:24 GMT+0200 (Mitteleuropäische Sommerzeit)
    G91               ; relative positioning
    G1 Z5 F6000 S2    ; lift Z relative to current position
    G1 S1 X-258 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F6000       ; go back a few mm
    G1 S1 X-258 F360  ; move slowly to X axis endstop once more (second pass)
    G1 Z-5 F6000 S2   ; lower Z again
    G90
    

    home y:

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Thu Oct 03 2019 16:43:49 GMT+0200 (Mitteleuropäische Sommerzeit)
    G91               ; relative positioning
    G1 Z5 F6000 S2    ; lift Z relative to current position
    G1 S1 Y-235 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000       ; go back a few mm
    G1 S1 Y-235 F360  ; move slowly to Y axis endstop once more (second pass)
    G1 Z-5 F6000 S2   ; lower Z again
    G90               ; absolute positioning
    

    home z:

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Thu Oct 03 2019 17:07:19 GMT+0200 (Mitteleuropäische Sommerzeit)
    G91              ; relative positioning
    G1 Z10 F6000 S2   ; lift Z relative to current position
    G90              ; absolute positioning
    G1 X115 Y105 F6000 ; go to first probe point
    G30              ; home Z by probing the bed
    
    ; Uncomment the following lines to lift Z after probing
    ;G91             ; relative positioning
    ;G1 S2 Z5 F100   ; lift Z relative to current position
    ;G90             ; absolute positioning
    

    thanks a lot



  • Seems you didnt define axis limits. You should have in your config file something like this: M208 X-120 Y-120 S1 and M208 X120 Y120 S0 (assuming your X and Y travel is 240 and you want 0 be in center). Look at https://duet3d.dozuki.com/Wiki/Gcode#Section_M208_Set_axis_max_travel



  • i have try it but its not in the center of the bed





  • @lui2004 said in need help to set Bed-Center and Origin 0,0 at the center:

    i have try it but its not in the center of the bed

    Hi,

    Do you mean it's nowhere near the center or is not in the exact center.

    Frederick



  • its not near the center.

    1,5cm x to be in center and y too



  • @lui2004 said in need help to set Bed-Center and Origin 0,0 at the center:

    its not near the center.

    1,5cm x to be in center and y too

    There are two ways to handle that.

    1. You can adjust the X and Y min values in your M208 command by that amount. You would add or subtract that amount depending on which side of center the axis homes.

    2. You can make an adjustment when homing X and Y. After they are homed use a G1 command to move as needed to be in the center, then use a G92 X0 or G92 Y0 command to declare that axis is now centered.

    I use the second approach.

    Now this is just something to think about and is related to using the second approach.

    Since I have an adjustment to obtain exact center in my homeX.g and homeY.g files I don't like to have the same adjustment appear somewhere else. Why? Because if I have to change it I have to remember to change each place.

    So my homeALL.g file is just:

    M98 PhomeZ.g
    M98 PhomeY.g
    M98 PhomeX.g

    Now this does prevent me from "optimizing" when homing all but I think it makes it simpler to maintain. Given the length of time prints take saving a few seconds when homing all doesn't really seem too important to me.

    Just an idea.

    Frederick



  • now i got it 😉

    i forgot to add the amount to M208 ,now it seems all fine

    thanks


Log in to reply