Z axis issues :) 0 - -405



  • Good evening.. So Ive been fighting an issue for a while (still working) in that my Z axis (cr-10) operates in the manner in which it should. I think.
    I click home, it goes down to end stop, hits end stop, shows 0

    However, the only keys that work are - . so i can go -25 and it goes UP (cr-10) and it reads -25
    I can then go +25 and it goes back down, of course.

    So obviously you can see why this is an issue. When I print anything, every layer it goes DOWN, not up. expecting to go in to plus territory, not minus.
    Is there 1 specific setting I should change to make it work the way i want? + not minus?
    Obviously direction isnt the fix, its something as to how its reporting to the duet that its at 0 or neg.
    IF i choose opposite direction for the steppers, they just move up, instead of down.
    thank you for your help. much appreciated.



  • It sounds like the direction of your Z motor needs to be reversed. But there is also the interplay of your endstop configuration and how your homing files are setup.

    These commissioning steps may help you identify what needs to be changed.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+3:+Commissioning/39



  • its really odd... everything is functioning properly when not printing... homing goes down, clicks, and zeros. +25 raises it 25. all good. When printing it just goes in reverse. strange.

    Also, the end stops done seem to stop the software from going past the endstop to drive the nozzle in to the bed. so while the end stop stops it during homing. it doesnt seem to stop it if I do a -25 after its at 0



  • Please post your config and homing files.

    It sounds like you have your motors reversed and the homing files are compensating for that.



  • this is home Z. (which I just copied in to home all when i got it working).
    G91 ; relative positioning
    G1 S1 Z405 F1800 ; move quickly to Z axis endstop and stop there (first pass)
    G1 Z+5 F6000 ; go back a few mm
    G1 S1 Z405 F360 ; move slowly to Z axis endstop once more (second pass)
    ;G1 Z-5 F6000 S2 ; lower Z again
    G91 ; relative positioning
    G1 S1 Z5 F100 ; lift Z relative to current position
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)
    G90 ; absolute positioning

    This is config.g

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.5 on Sat Nov 02 2019 00:12:09 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"LaBarre CR10" ; set printer name

    ; Network

    M552 S1 ; enable network
    M587 S"" P"******"
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 F6000 ; physical drive 0 goes forwards
    M569 P1 S1 F6000 ; physical drive 1 goes forwards
    M569 P2 S0 F6000 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E93.00 ; set steps per mm
    M564 H0
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z600.00 E200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z300.00 E250.00 ; set accelerations (mm/s^2)
    M906 X750 Y750 Z750 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 S1
    M208 Z0 S0 ; set axis minima
    M208 X300 Y300 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X2 Y2 Z2 S1 ; set active low and disabled endstops

    ; Z-Probe
    ;M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    ;M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4267 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S350 ; set temperature limit for heater 1 to 350C

    ; Fans
    ;M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ;M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ;M106 P2 S1 IO F500 H1
    ; Fans
    M106 P1 B0 X0.6 S0.3 I0 F100 H1 T120 C"Hotend" ; Set fan 1 (extruder fan) value, PWM signal inversion and frequency. Thermostatic control is turned ON
    M106 P0 B0 S0.0 I0 F30 H-1 C"Part" ; Set fan 0 (part cooling) value, PWM signal inversion and frequency. Thermostatic control is turned OFF

    ; Tools
    M302 P0
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • @dunginhawk said in Z axis issues 🙂 0 - -405:

    G1 S1 Z405 F1800 ; move quickly to Z axis endstop and stop there (first pass)
    G1 Z+5 F6000 ; go back a few mm
    G1 S1 Z405 F360 ; move slowly to Z axis endstop once more (second pass)

    ; Endstops

    M574 X2 Y2 Z2 S1 ; set active low and disabled endstops

    Your Z homing direction and endstop position are incorrect.

    The CR-10 homes the z axis to 0 at the bed position. However, your endstop is defined as being at the high end (Z2) rather than the low end (Z1). Therefore you had to modify your homing direction to move positive (Z405) rather than negative.

    Look at homez line by line. you're telling it to move in the positive direction 3 times in a row and then setting it at Z0.

    I think your x axis endstop position is wrong as well since it is on the left side of the printer at the low end of travel, yet you have it set as being on the high end of travel. Same for the Y axis.

    Change the endstop definition to be M574 X1 Y1 Z1 S1.

    Then you will have to change the homing files to move in the negative direction to move towards the endstops.

    Check the link I posted earlier which goes through testing your endstops and homing directions.



  • thank you phaedrux. ill get started there... ive been through the docs before... so much doesnt make sense... Ive owned a dozen or so printers, but its been years since ive done anything like this... its just so out of practice for me. thank you



  • Actually just ended up rebuilding it from scratch in the configurator...
    Only had to change directions on Y and Extruder.
    Everything else seems to be working perfectly.
    lets see how it goes with a few test prints.



  • If you just flipped a motor direction you'll probably end up with mirrored prints.

    0,0 should be in the front left corner



  • the Y was just moving opposite when I homed it... so i reversed it..
    we shall see 🙂 prints are looking good though.

    And yes, the bed is all the way back against endstop, and X is left, so 0 0 is front left 🙂


Log in to reply