M204 and pressure advance and travel acceleration?



  • Hi there,

    1. I want to optimize the print quality. For this i reduced the acceleration given in M201 to 800mm/s^2. But i also want to have high speed travel moves (200mm/s). For this an acceleration of 3000mm/s^2 would be better...

    Can i set the Travel acceleration to 3000mm/s^2 with the M204 command to reach this goal? (Have slow print accs while having high travel accs)

    1. I still can't use pressure advance and still wonder why others using e-jerk values about 3600mm/min. If i do this the BMG will make bad noises. (e-acc is 3600mm/s^2; PA=0.4) If i lower the e-jerk to 120mm/min the print speed will slow down also the effect of PA is gone because the speed at corners will be so slow... If i put M204 in the console after a emergency stop (clean load of my config.g) it will return:

    M204
    Maximum printing acceleration 10000.0, maximum travel acceleration 10000.0

    But in my config.g there is no M204 defined. Is it possible that my extruder gone wild with PA enabled because of these high acc-value?

    Thank you very much 🙂


  • administrators

    @PuddingBaer91 said in M204 and pressure advance and travel acceleration?:

    1. I want to optimize the print quality. For this i reduced the acceleration given in M201 to 800mm/s^2. But i also want to have high speed travel moves (200mm/s). For this an acceleration of 3000mm/s^2 would be better...

    Can i set the Travel acceleration to 3000mm/s^2 with the M204 command to reach this goal? (Have slow print accs while having high travel accs)

    That's the wrong way round. Set the M201 acceleration to the highest value that you ever want to use. You can reduce and printing and/or travel acceleration for particular prints using M204.

    1. I still can't use pressure advance and still wonder why others using e-jerk values about 3600mm/min. If i do this the BMG will make bad noises. (e-acc is 3600mm/s^2; PA=0.4) If i lower the e-jerk to 120mm/min the print speed will slow down also the effect of PA is gone because the speed at corners will be so slow...

    Try reducing E acceleration. is it a genuine Bondtech BMG?

    If i put M204 in the console after a emergency stop (clean load of my config.g) it will return:

    M204
    Maximum printing acceleration 10000.0, maximum travel acceleration 10000.0

    But in my config.g there is no M204 defined.

    Those are the default values, designed to have no effect because they are higher than normal M201 values. the actual acceleration will be the lower of the M203 value and the M204 value.

    Note, if you are using dynamic acceleration adjustment (M593) then you should not normally use M204 to reduce accelerations.



  • @dc42 said in M204 and pressure advance and travel acceleration?:

    @PuddingBaer91 said in M204 and pressure advance and travel acceleration?:

    1. I want to optimize the print quality. For this i reduced the acceleration given in M201 to 800mm/s^2. But i also want to have high speed travel moves (200mm/s). For this an acceleration of 3000mm/s^2 would be better...

    Can i set the Travel acceleration to 3000mm/s^2 with the M204 command to reach this goal? (Have slow print accs while having high travel accs)

    That's the wrong way round. Set the M201 acceleration to the highest value that you ever want to use. You can reduce and printing and/or travel acceleratoinit for particular prints using M204.

    ahh okay i think i got it. Now my settings look like this:
    M201 X3000 Y3000 Z100 E10000 ; Set max accelerations (mm/s^2)
    M204 P1500 T3000 ;Set accelerations for print and travel moves (mm/s^2)
    correct?

    1. I still can't use pressure advance and still wonder why others using e-jerk values about 3600mm/min. If i do this the BMG will make bad noises. (e-acc is 3600mm/s^2; PA=0.4) If i lower the e-jerk to 120mm/min the print speed will slow down also the effect of PA is gone because the speed at corners will be so slow...

    Try reducing E acceleration. is it a genuine Bondtech BMG?

    yes it's a orginal BMG with 80-90cm bowden tube. Already tried to reduce e-acc but doesn't help. I tried with 3600 for jerk and 3600 for acc like others using with good results... but mine sounds not good so i won't use PA

    If i put M204 in the console after a emergency stop (clean load of my config.g) it will return:

    M204
    Maximum printing acceleration 10000.0, maximum travel acceleration 10000.0

    But in my config.g there is no M204 defined.

    Those are the default values, designed to have no effect because they are higher than normal M201 values. the actual acceleration will be the lower of the M203 value and the M204 value.

    Note, if you are using dynamic acceleration adjustment (M593) then you should not normally use M204 to reduce accelerations.

    don't use dynamic at the moment

    thank you for the help


Log in to reply