Commissioning Duet 0.8.5 and Duex4 v0.2a Setup



  • Hi

    I am in the process of commissioning my Duet 0.8.5 and Duex4 v0.2a Setup.
    I bought them from Think3dPrint3d a number of years ago. This is my first time using them.
    I have successfully setup and tested the Duet 0.85 board on its own and had a successful print.
    The configuration was created using the "RRF Config Tool"
    I am now in the process of setting up the Duex4 v0.2a board.
    I have connected the ribbon cable and run a separate V+ from my power supply to the Duex4. I have connected a shorter wire from the Duet 0.8.5 -ve connector to the Duex4 -ve connector.

    I will be adding a Diamond Hot End to the Duex4

    The additional code that I have added to the config.g file is follows

    M569 P5 S1 ; physical drive 5 goes forwards Ex3 (Diamond)
    M569 P6 S1 ; physical drive 6 goes forwards Ex4 (Diamond)
    M569 P7 S1 ; physical drive 7 goes forwards Ex5 (Diamond)

    M305 P3 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 3 (Diamond)
    M143 H3 S280 ; set temperature limit for heater 3 to 280C

    M106 P3 S1 I0 F500 H3 T45 ; set fan 3 value, PWM signal inversion and frequency. Thermostatic control is turned on

    M563 P2 S"Diamond" D2:3:4 H3 F2 ; define tool 3
    G10 P2 X0 Y0 Z0 ; set tool 2 axis offsets
    G10 P2 R0 S0 ; set initial tool 2 active and standby temperatures to 0C

    The Web interface shows the "Diamond" tool added and the additional extruder motors.
    There is a single red LED lit on the Duex4 at location D5.

    I have tried connecting my thermistor into the Duex4 and no measurement is recorded (2000.0C on the Web interface)
    I have tried it at all the possible locations for thermistors shown in the wiring diagram
    https://reprap.org/wiki/File:Duet_0.8.5_Duex4_wiring_0.2.svg
    (my board has the pin connectors rather than the screw connectors)
    I have tested the thermistor by connecting it to the Duet board and it gives a believable reading.

    The M115 command does not list the Duex4
    FIRMWARE_NAME: RepRapFirmware for Duet FIRMWARE_VERSION: 1.24 ELECTRONICS: Duet 0.85 FIRMWARE_DATE: 2019-06-13b2
    Should the Duex4 be listed here?

    Do I have a problem here? Have I miss-configured my system?

    I will post the M122 output in a reply post.

    I have an existing problem where the heater for T0 is continuously on. I am currently ignoring that as I don't intend to use it. However it is possible that it might be relevant here.

    Thanks in advance.
    Jamesconfig.g



  • M122
    === Diagnostics ===
    RepRapFirmware for Duet version 1.24 running on Duet 0.85
    Used output buffers: 3 of 16 (16 max)
    === System ===
    Static ram: 44204
    Dynamic ram: 42812 of which 3096 recycled
    Stack ram used: 136 current, 3428 maximum
    Never used ram: 4764
    === Platform ===
    Last reset 01:39:41 ago, cause: power up
    Last software reset at 2019-11-13 21:33, reason: User, spinning module GCodes, available RAM 5004 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x00000000 BFAR 0xe000ed38 SP 0xffffffff
    Error status: 4
    Free file entries: 10
    SD card 0 detected, interface speed: 10.5MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 3.5, current 26.5, max 28.6
    Date/time: 2019-11-14 16:23:19
    Slowest loop: 60.74ms; fastest: 0.10ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 100, MinFreeDm: 97, MaxWait: 2213185ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 10, completed moves: 10, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is assembling a command in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Free connections: 15 of 16
    Free transactions: 23 of 24
    Locked: 0, state: 4, listening: 20071bf4, 0, 0



  • @JUNK said in Commissioning Duet 0.8.5 and Duex4 v0.2a Setup:

    Error status: 4

    It looks like I have an error, Where I I find out what this means please?


  • administrators

    The thermistor series resistors on most DueX4 boards are 1K. So you probably need R1000 in the M305 P3 command, not R4700. Alternatively, connect the thermistor to the Duet.



  • DC42
    I have not been able to get a reading from the thermistor when connected to the duex4 with the change you suggested. It does work when connected to the duet. I have noticed that M115 does not list the duex4. Should it be showing it? Do I have a more fundamental problem?

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet FIRMWARE_VERSION: 1.24 ELECTRONICS: Duet 0.85 FIRMWARE_DATE: 2019-06-13b2

    Thanks

    James


Log in to reply