Config tool M667 / M669 and disable PWM channel bug?



  • Using Duet WIFI and still struggling.

    In REPRAP confg tool (V 2.1.3) I select Core XY, still the config.g file generated at the end keeps inserting M667 S1, although my firmware version is 2.03. Shouldn’t I get automatically a M669 k1 instead?

    I guess I can always manually change it at config.g file at "System" in the console.

    Because I’m going to use BL Touch as Z probe (and end stop) I selected “E3 Chanel” to disable the appropriate PWM channel at PIN8. Again when I open the config.g file generated by the reprap tool It shows “M307 H4 A-1 C-1 D-1”. Shouldn’t be M307 H3.....?

    Thanks


  • administrators

    @MJCT said in Config tool M667 / M669 and disable PWM channel bug?:

    In REPRAP confg tool (V 2.1.3) I select Core XY, still the config.g file generated at the end keeps inserting M667 S1, although my firmware version is 2.03. Shouldn’t I get automatically a M669 k1 instead?

    Unless you need to change the movement matrix, it doesn't matter, because M667 is still supported apart from the old scaling factor parameters. We don't intend to withdraw M667.

    Because I’m going to use BL Touch as Z probe (and end stop) I selected “E3 Chanel” to disable the appropriate PWM channel at PIN8. Again when I open the config.g file generated by the reprap tool It shows “M307 H4 A-1 C-1 D-1”. Shouldn’t be M307 H3.....?

    The bed heater output is heater 0 (H0), extruder 0 is H1 and so on. So the output labelled E3 Heat is H4.



  • @dc42 Many thanks!


Log in to reply