Auto tune cancelled because temperature peak was not identified



  • I thought I'd better re tune my heaters since upgrading to 1.18.1. - got this when doing the bed:

    09:20:05 Auto tune cancelled because temperature peak was not identified
    09:19:58 Auto tune phase 2, heater off
    09:09:26 Auto tune phase 1, heater on
    09:09:20 M303 H0 S80
    Auto tuning heater 0 using target temperature 80.0C and PWM 1.00 - do not leave printer unattended

    Couldn't find any info in the Wiki as to what to do in this instance.

    It is a large 400mm x 400mm x 10mm aluminium plate with the temperature sensor fitted in a hole about 30mm deep in the side of the bed, close to the surface. The heater is a 240V silicone heater (can't remember the wattage off hand).

    It seems that the sensed temperature continues to rise for a while after the heater has turned off - probably because it takes a while for the heat to "percolate" through the plate and that maybe the firmware wasn't allowing enough time??

    I only selected 80 degrees C because I never use more than 60 so it cuts down the tuning time. I can try it higher if that will help (say 140?). Also, I used the default 1.0 PWM value so I can try lowering it. What's best to do? It's not urgent because the bed heats OK with the previous parameters.

    Thanks

    Ian


  • administrators

    Hi Ian,

    On reaching the target temperature, the firmware switches the heater off, then watches for the temperature to continue rising and then start falling. It allows 2 minutes for this. Can you tell me what happens to the temperature reading on your bed if you command it to e.g. 100C and then switch it off when it reaches 80C, for the 2 minutes after you switch it off?



  • Hi David,

    Yes I can do but the message appeared much sooner than 2 minutes after the heater went off. Wait a minute …..... yes it's there in the times that I posted. 09:19:58 heater off. 09:20:05 auto tune cancelled because temperature peak not identified. So 7 seconds not 2 minutes.

    For info, I'm on the latest firmware 1.18.1 (2017-04-09). Immediately prior to tuning the bed heater, I did a successful tune of the hot end heater and ran M500. As far as I can remember, I did nothing else in between. Hope that gives you some clues.

    Ian



  • One other thing - it's Duet Ethernet, not Duet Wifi (shouldn't make any difference I'd have thought but just in case).



  • Just ran that test. i.e. Heater demand set to 100, turned off at 80, temperature readings taken ever 10 seconds thereafter.
    T0 80.0
    T10 80.5
    T20 81.1
    T30 81.3
    T40 81.3
    T50 81.3
    T60 81.2
    T70 81.1
    T80 80.8
    T90 80.6
    T100 80.4
    T110 80.2
    T120 80.0

    So peak was around 30 to 50 seconds after heater off and would have been OK with the 2 minutes wait, but it seems that in this case, the reading was taken after 7 seconds and not 2 minutes as expected.

    HTH. Let me know if you ned me to run any more tests.


  • administrators

    With those readings, I would expect the auto turning to work without any problem. I wonder whether you got a spurious reading that made it look as if there were 2 peaks?



  • I'll test again. Just seemed strange that it reported the error message only 7 seconds after the heater was turned off - nothing like the 2 minutes you mentioned.



  • Tried again. Same thing. Auto tune cancelled because temperature peak was not identified 7 seconds after heater off. Nothing preceded the test. That is to say I just turned on the machine then issued M303 H0 S80. Here is another copy and paste from the gcode console.

    08:34:17 Auto tune cancelled because temperature peak was not identified
    08:34:10 Auto tune phase 2, heater off
    08:23:46 Auto tune phase 1, heater on
    08:23:40 M303 H0 S80
    Auto tuning heater 0 using target temperature 80.0C and PWM 1.00 - do not leave printer unattended
    08:22:16 Connection established!
    08:22:16 Page Load complete!

    Maybe it's the low target temperature that it doesn't like. I'll try again with a higher setting once the bed has cooled (unless anyone comes up with a better idea in the meantime).



  • Just tried again with the target temperature set to 100. I had to increase the maximum temperature in config.g because I had that set to 100. Same result only this time the error message appeared 18 seconds after heater off rather than the 7 seconds it takes using a target temperature of 80. Here is the relevant "cut and paste" from the console.

    10:40:56 Auto tune cancelled because temperature peak was not identified
    10:40:38 Auto tune phase 2, heater off
    10:26:38 Auto tune phase 1, heater on
    10:26:32 M303 H0 S100
    Auto tuning heater 0 using target temperature 100.0C and PWM 1.00 - do not leave printer unattended
    10:25:08 M303 H0 S100
    Target temperature must be below temperature limit for this heater



  • Tried yet again with the target set to 140 which is what I think I used when I last successfully tuned the bed heater on earlier firmware. This time I got this:

    14:10:46 Auto tune cancelled because target temperature was not reached
    13:50:46 Auto tune phase 1, heater on
    13:50:40 M303 H0 S140
    Auto tuning heater 0 using target temperature 140.0C and PWM 1.00 - do not leave printer unattended

    I tried manually heating the bed to 140 and it does get there - just takes while longer than the auto tuning will allow. If I recall correctly, when I tuned the bed before using an older firmware version, I think I had a message to the effect that the heater was over powered and could reach 500 plus deg C.

    Not sure what to try now. I'm guessing comment out the old M307 for heater 0 and try again?


  • administrators

    Looks like I need to change the peak detection code to accept a fall of in the rate of increase of temperature instead of an actual peak. My guess is that your bed cools so slowly that noise is preventing the code from seeing a single peak.

    The auto tune code allows 20 minutes for the target temperature to be reached when tuning a bed or chamber heater, or 5 minutes when tuning an extruder heater.



  • Hi David,

    Yes the bed is 10mm thick and has 12mm insulation underneath so it takes forever to cool (but it does reach a peak about 30 to 50 seconds after heater off and drops slowly back to the set temperature after 2 minutes. Also, I'd say there is probably 0.2 degrees of noise in the readings as well, - ( I'm using a 4 wire pt100).

    I just tried again and even in bang bang mode, after 20 minutes my bed reaches 128 deg C from a starting temp of 30. I'd normally only want to use 60 degrees max so that's not an issue for me but you might want to mention the 20 minute limit in the wiki, just in case someone else tries to tune a big bed to a high temperature at some time in the future.

    It's on my list of things to do, to change the bed from 10mm to 8mm. I can't see it having any detrimental effect even though it's 400mm square. It'll speed up the warm up time but it's a fair bit a hassle to do, (and I'd have to buy another silicone heater because I doubt that I'd be able to unstick the one I have without destroying it).

    I can run with the original settings or bang bang mode for now. It all works so it's no big deal. Let me know if and when you want me to test any new code.

    Ian



  • @dc42:

    Looks like I need to change the peak detection code to accept a fall of in the rate of increase of temperature instead of an actual peak. My guess is that your bed cools so slowly that noise is preventing the code from seeing a single peak.

    The auto tune code allows 20 minutes for the target temperature to be reached when tuning a bed or chamber heater, or 5 minutes when tuning an extruder heater.

    Has anything been done in regards to this? I am seeing the same problem. 300x300x6 bed with 120v 600w heater. Get up to temperature in under 4 minutes then get the peak not detected message about 30 seconds later.


  • administrators

    It's still on my list to do something about. Meanwhile, you may find it helps to have the print cooling fan turned on and blowing on the bed. Or you can use the manual tuning method.



  • Hi David and Ian, I too have experienced all of the above issues discussed over the past year. I have found workarounds and ended up setting things up manually with crazy numbers like A100 C1000 D200. I sure would like to be able to use auto tune but same a Ian I have a huge thermal mass at 10mm think 800 square mm. I have been able to to get past some of my problems with setting M570 H0 P300 T30 ; Load new Heater Fault parameters. The thing that has been stopping me from completing autotune it the 2 min limit to cool down. I will overshoot about 28c but it will take more than 2 min to start coming down. Is there anything I can do to on my end to increase that limit? I think this is an important thing to nail down as more and more high performance and more pro like machines have bigger platens.

    Thanks for the help!

    Werner



  • David,

    Did you ever get around to looking at this? TBH I'd forgotten all about it myself so haven't tried tuning the bed heater since starting this thread.

    Ian


  • administrators

    Thanks for the reminder, I'll try to include a fix in the next beta.



  • I meant to say that I tested this the other day using latest 1.19 beta11 and it's likely fixed. That is to say it did report a peak after phase 2 although the peak was reported at 7 seconds after heater off but the true peak was about 1.4 degrees higher and occurred at around 100 seconds after heater off. I can't say what would happen after that as it takes my bed an awful long time to cool down and DWC disconnected (reason - timeout) before phase 3 completed.



  • I had this issue the other day when trying to tune mine I sent a manual D param of d60 and that seemed to allow it to complete?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.