E1 Heater not working - check for board defect?



  • Hi,
    I'm trying to connect 3 SSRs to control heaters to a duet 2 ethernet with an Expansion Header Breakout Board. I managed to get H0 and H1 working, but H2 isn't. When I switch the heater on through DWC no voltage is measured at the clamps on E1. I'll attach the config below, I think it should be correct.
    Could this just be a defective board? Is there a way to use a PWM output from one of the fans to control the SSR instead of E1?

    Best regards
    Patrick

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Thu Dec 05 2019 17:48:56 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"-----" ; set printer name

    ; Network
    M551 P"------" ; set password
    M552 P192.168.1.14 S1 ; enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P5 S1 ; physical drive 5 goes forwards
    M584 X0 Y1 Z2 E5 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E224.6 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X2500 Y2500 Z1500 S0 ; set axis maxima

    ; Endstops
    M574 X0 Y0 Z0 S0 ; set active low and disabled endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M140 H-1 ; kein bed
    M305 P0 T4606017 B5848 C5.548428e-8 R4700 S"Einzugszone" ; set thermistor + ADC parameters for heater 0
    M143 H0 S250 ; set temperature limit for heater 0 to 250C
    M307 H0 B1
    M305 P1 T4606017 B5848 C5.548428e-8 R4700 S"Kompressionszone" ; set thermistor + ADC parameters for heater 1
    M143 H1 S500 ; set temperature limit for heater 1 to 500C
    M307 H1 B1
    M305 P2 T4606017 B5848 C5.548428e-8 R4700 S"Düse" ; set thermistor + ADC parameters for heater 2
    M143 H2 S500 ; set temperature limit for heater 2 to 500C
    M307 H2 B1

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2:3 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Extruder" D0 H0:1:2 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    ;G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    ;T0 ; select first tool



  • @PatrickC93 said in E1 Heater not working - check for board defect?:

    M563 P0 S"Extruder" D0 H0:1:2 F0 ; define tool 0

    can you test with H2 alone. normally H0 is not part of the tool

    @PatrickC93 said in E1 Heater not working - check for board defect?:

    ;T0 ; select first tool

    you might want to enable this. without a tool selection you can not heat up.

    @PatrickC93 said in E1 Heater not working - check for board defect?:

    M307 H2 B1

    why do you want bang bang on the heaters?



  • Hi @Veti,
    thanks for taking a look.
    I tried with defining H0 as Bed again and just H1 & 2 for the Tool, same problem.

    The Bang-Bang is just for testing purposes, i will tune in later. The heaters control SSRs that then switch on 220VAC coils for heating. They have LEDs that light up when active which can be invisible to the human eye if the flashes are too fast. Also they heat up the barrel of a screw extruder which has a lot of thermal mass. H1 worked without enabling T0 but I tried anyway, no difference.



  • I checked the heater configuration on a duet 2 wifi and i can't get H2 to work there either. which makes a defective board less likely. Is there a jumper or something on the board I need to change?





  • I took a look at the mosfets, all 3 look identical and fine. Also checked the terminal connectors on the underside, no fault there.
    I measured the two mosfets next to E1 and E2 from source to drain. has 24 V the other shows 0. So I guess the fault is somewhere further up the circuit.



  • On the back of the board there are small soldered spots labeled TP6 to TP11, TP8 is not soldered, all others are. The Mosfet that is not working is labeled TR8. Could this be linked?



  • that has to be answered by @dc42

    is it soldered on your duet wifi?





  • Should I still check on the Duet Wifi? I'd have to disassemble quite a bit of a printer to look at the underside so I'd rather not if this has already checked out as not related.



  • lets wait for what @dc42 has to say about the missing solder spot.

    can you post a picture about the missing solder for him?



  • IMG_20191206_174245.jpg

    its on the bottom right of the picture



  • I might have found a work around. Since I have a expansion header there should be heaters 6 & 7 on there. I only need three so if H2 won't work I could switch to H6 instead, but I'm a little unsure if I got the wiring correct as there is a 5V pin in between. so based on this: https://duet3d.dozuki.com/Wiki/Duet_Expansion_Breakout_Board
    I could connect my SSR to Heater 6 PWM and GND and just leave the 5V pin unused. Correct?



  • So the system is running now. it would still be nice to know what causes the e1 heater not to work since I seem to have the same issue on both the duet 2 ethernet and duet 2 wifi I bought. it's either a huge coincidence or recurrent quality problem.


  • administrators

    @PatrickC93 said in E1 Heater not working - check for board defect?:

    IMG_20191206_174245.jpg

    its on the bottom right of the picture

    The lesser amount of solder on TP8 is not significant. The tests run by our automated test equipment include the E1 heater output.

    The only unusual thing I can see in your config.g file is that the heater name for the M305 P2 command includes an umlaut in the character string. That should be OK if you saved the file in UTF8 format, nevertheless I suggest you try it with the umlauted character removed or replaced.



  • Hi @dc42 ,

    thank you for taking a look at it. I tried first without the Umlaut and it didn't work. I also switched around the name to heater H0 now, as that will be much more active than the "Einzugszone" which I'm controlling with H6 now.
    I guess it may have been damaged during shipping or installation if you run testing on it but the packaging looked fine and with all the foam inside it's hard to imagine it beeing damaged during travel. During installation we were careful, but who knows, maybe not careful enough.
    Anyway we have it running now and will start printing this week.

    Thanks for your time @dc42 & @Veti !


  • administrators

    @PatrickC93, I am happy to approve a warranty replacement for your Duet. It's possible that it has an intermittent fault that didn't show up during our testing.


Log in to reply