Is my Duet ethernet sd card empty?



  • After having troubles with the duet Wifi i went the Ethernet route. I got my card to read through usb saying Duet WiFi or Ethernet 3D printer control electronics (COM3). I can connect using Repetier which says

    17:47:52.180 : OpenGL renderer:GeForce GTX 980/PCIe/SSE2
    17:47:52.180 : Using fast VBOs for rendering is possible
    17:48:08.307 : No start signal detected - forcing start
    17:48:08.338 : N1 M11034
    17:48:08.338 : N2 M115
    36
    17:48:08.338 : N3 M10536
    17:48:08.338 : N4 M114
    35
    17:48:08.338 : N5 M111 S698
    17:48:08.354 : N6 T0
    60
    17:48:08.354 : N7 M8028
    17:48:08.370 : N8 M105
    47
    17:48:08.385 : RepRapFirmware for Duet Ethernet Version 1.18.1 dated 2017-04-09
    17:48:08.385 : Executing default.g (no configuration file found)…Error, not found
    17:48:08.385 : Network disabled.
    17:48:08.385 : RepRapFirmware for Duet Ethernet is up and running.
    17:48:08.385 : ok
    17:48:08.385 : FIRMWARE_NAME: RepRapFirmware for Duet Ethernet FIRMWARE_VERSION: 1.18.1 ELECTRONICS: Duet Ethernet 1.0 FIRMWARE_DATE: 2017-04-09

    However when i put the sd card in my computer to put my IP address in sys/config.g its not thier. The sd card is blank. Says (G:) 7.20gb free of 7.20GB. I click on it and its empty. I can add a file to it and everything if i want. Am i missing something can this sd card really be empty yet work in Repetier?

    I found the sd card folder structure here https://duet3d.com/wiki/SD_card_folder_structure
    If i need to add the files where do i get them?



  • ok i found out i can just write the ip in repetier. https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer

    still having trouble after this step. I wish i had more detailed instructions than. https://duet3d.com/wiki/Getting_connected_to_the_Duet_Ethernet_or_Duet_0.8.5



  • Im getting close

    19:28:58.454 : Network is enabled, configured IP address: 0.0.0.0, actual IP address: 192.168.1.123

    when i type the 192.168.1.123/ in the browser it stays blank and i get this on repetier.
    19:31:40.860 : serial: N70 M10516
    19:31:40.860 : ok T:B:-273.1
    19:31:41.656 : Incoming transaction: Type receiving at local port 80 (remote port 53778)
    19:31:41.656 : HTTP req, command words { GET / HTTP/1.1 }, parameters { }
    19:31:41.656 : Can't open 0:/www/reprap.htm.gz to read, error code 12
    19:31:41.656 : Can't open 0:/www/reprap.htm to read, error code 12
    19:31:41.656 : Can't open 0:/www/html404.htm to read, error code 12
    19:31:41.656 : Webserver: rejecting message with: not found
    19:31:41.656 : ConnectionLost called for local port 80 (remote port 53778)
    19:31:43.922 : N71 M105
    17
    19:31:43.922 : serial: N71 M105*17

    i did change M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address like on https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer. maybe thats messing me up idk



  • Ensure that the /www folder on the SD card is populated with the required web files. So i guess thats whats stopping my page to load because its just blank no error or nothing.



  • wow so that was it.

    If you want to do this start with installing duetwebcontrol on the sd card you will find here.
    https://github.com/dc42/RepRapFirmware/tree/dev/Release/Duet-Ethernet/Stable

    make sure it looks like this on your card
    https://duet3d.com/wiki/SD_card_folder_structure

    download the device driver zip to your PC and make sure your device manager reads your duet with the sd card installed
    https://github.com/dc42/RepRapFirmware/blob/dev/Driver/DuetDriverFiles.zip

    load repetier and connect

    send M552 command and you should see this
    Network is disabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0

    install your ethernet and send M552 S1 to turn it on
    19:57:33.309 : Network is enabled, configured IP address: 0.0.0.0, actual IP address: 192.168.1.123
    you should see something like this.

    load a browser and enter the IP your duet gave you in the browser. 192.168.1.123/


  • administrators

    I'm sorry that you appear to have been send a board with an empty SD card.

    The production process is being changed so that in future, boards will be tested using the same SD card that they will ship with, instead of testing them with one SD card and shipping them with a different one as now.


Log in to reply