RRF3 homing problem



  • Hi, after the update to RRF3.0RC1 I found a problem with the homing Z axis. The Z axis is composed of 2 motors and 2 independent limit switches installed on duex 5. The problem is that during homing the motors do not they stop when the limit switch changes state but continue further and stop much later or do not stop completely. Running M119 the position of the limit switches is correct. I tried to perform a downgrade to RRF3 Beta12 where everything worked correctly and the problem persists. I also tried replacing my duet wifi delivered last monday with an old one I have and I still have the same problem.
    I assume that the problem concerns duex5, ideas or advice?


  • administrators

    1. Use M115 to check whether the firmware downgrade was successful.
    2. Please post your config and homing files.


  • Hi David, I had already checked the built installed with M115. I forward my configuration file and homing files.
    The U and V axes are additional axes for lifting the head and for a cleaning trolley, I also encounter the same problem on those axes. Basically everything installed on the duex5 creates problems.
    In RRF3 RC1 ho modificato M574 da S0 a S1, per il resto è rimasto tutto invariato.
    homez.g homeall.g config.g



  • @dc42,You have some news?



  • @dc42 , it is possible that the problem is caused by a short circuit in the heated bed?


  • administrators

    @Marco-Bona said in RRF3 homing problem:

    Basically everything installed on the duex5 creates problems.

    When you send M115 to check the firmware version, does the response mention the DueX5 ? If the DueX isn't being detected, that would explain the problem.

    @Marco-Bona said in RRF3 homing problem:

    it is possible that the problem is caused by a short circuit in the heated bed?

    Why did you ask - did you have such a short circuit?



  • Duex 5 is detected correctly. I ordered a new duex5 board thinking it was damaged but the problem remained. So I started to check the electrical wiring and it seems that by unplugging the heated bed the error disappears.
    Another problem I have encountered is that panel two continues to restart, I think while the bed is working (I have yet to verify that disconnecting the bed panel due is working properly)


  • administrators

    Check that you have a short thick ground wire directly between the VIN terminal blocks of both boards, and the terminal block screws are tight. Without that, the pulsed bed heater current could interfere with the communication between the Duet and the X5.



  • @dc42, the connection beetwen duet and duex is correct, I followed these instructions (https://duet3d.dozuki.com/Wiki/Duex2_and_Duex5_Features).
    I think the problem is due to a leakage of current between the heated bed's ssr and the power supply. Ssr does not appear to be damaged. I'll update you as soon as possible



  • @dc42 ,
    I checked the electrical wiring and it all seemed correct. Now I have disconnected everything except the motors and the limit switches of the Z axis and I encounter the overtravel problem only on one motor (E6), so I tried to invert the limit switches and I would have expected to find the same problem, instead I find it on the E5 motor .
    Can you verify it?



  • @dc42 , I continued to investigate and connecting the Z and W axis in duet wifi everything works correctly. Even the X \ Y that I moved to duex5 seems to be working properly. Apparently M584 X0 Y1 U5 V6 Z8: 9 W9 E3: 4 P3 can generate problems on duex5.
    Can you verify that what I say is correct?


  • administrators

    You said you are using RRF 3.0RC1. Have you tried version 3.0 stable yet?



  • @dc42 , I have upgraded to stable RRF3.0 and am trying with this one, I have not tried with previous versions


  • administrators

    Hi Marco,

    Please change your M574 commands to use S1 instead of S0. If the switches are active low then you need to use ! at the start of the pin names. If they are active high then you do not.

    I have tested your config and Z homing files on my test rig, and Z homing is working for me. I am using firmware 3.01beta1. I changed all the M574 commands to use S1 instead of S0, and I removed the ! at the start of the pin names in the M574 commands because I am using normally closed (so active high) switches.

    BTW, RRF3 supports multiple endstop switches natively. So you do not need to create the W axis. Just list the endstop switches in the M574 command, for example: M574 Z2 S1 P"duex.e5stop+duex.e6stop". I have tested this too.



  • Hello @dc42, I updated to the latest version of RRF3.01, now I have inverted the X \ Y axes with E5 \ E6 axes. Momentarily I solved by inserting M140 S0 in the homing files, so the problem is the wiring between the pins of the bed on the duet and the SSR that activates it. Is there a filter that I can put between duet and SSR to eliminate the problem?



  • I have come to the conclusion of the problem. The problem concerned the faulty power supply that occasionally went to ground, moreover my machine is completely made of aluminum and therefore created disturbances on the supports of the SSRs which in turn sent the duet to ground.
    For twenty days I did tests with the new power supply and I didn't find any problems.
    Sorry @dc42 dc42 for reporting a problem with the firmware that actually had nothing to do with the real problem.


  • administrators

    I'm glad you solved it. Thanks for letting us know.


Log in to reply