Example gcode for rrf3 and m585 is Not working



  • See https://duet3d.dozuki.com/Wiki/Gcode#Section_M585_Probe_Tool

    Currently
    M558 K1 P4 C"!e0_stop" ; create probe #1 for use with M585, active low

    Must be
    M558 K1 P5 C"!e0_stop" ; create probe #1 for use with M585, active low



  • Documentation fixed.



  • My only problem is, this does not work.

    I configured my probes in config.g:

    ; Configure Inputs
    ; E0 - ToolHead-Offset
    M581 T2 P"!e0stop" C0       ; Monitor endstop E0 for a rising edge Signal (NO - normally open Switch, active high), calling macro-file trigger2.g at any condition
    
    ; Probes
    M558 K0 P5 C"!zprobe.in"   H5 R0.000 A30 B0 S0.01 F200 T2000  ; Setup the Z-Probe (switch, active high)
    M558 K1 P5 C"!e0stop"                                         ; Setup the Calibration-Probe (switch, active high)
    

    and touching the probe creates the trigger as planned. But when running the following code in bed.g, the probe will not stop the motion or trigger like normal, until its already too late.

    M98 P"position_calibration_nozzle.g"   ; Move to BedSensor
    
    M208 Z-3 S1        ; Enable Movement below the PrintBed (override Z-min)
    
    G1 Z5 F200         ; Move to defined Z-Position
    M585 P1 L0 S1 F50 Z-5.15  ; Probe BedSensor (Offset to Bed: 0.15mm)
    
    M400               ; Make sure everything has stopped
    G4 P1000           ; Wait a Second
    m81
    G10 P0             ; Show Offsets
    M114               ; Show Position
    


  • I tried to investigate the problem a little further and found that when touching probe K0 the movement of M585 stops. So this has then to be fixed in firmware, i think.



  • Yeah, oddly enough, I am experimenting with probing for a multi-tool at this moment. And I was using various G0 H3. Decided to try M585 last night.

    I am absolutely certain the wiring and IO pin are correct, because it stops a G0 H3 move. However, the M585 does not appear to stop.

    A M558 K1 (with no other parameters) does show probe 1 is defined. I don't see any way (including looking at the raw JSON) to determine if a probe other than zero is triggered.

    Anyway: M585 does not stop when contact is made, when a probe other than 1 is specified. @dc42 is this a "not quite there yet" for RRF3?



  • I solved it for the moment by deassigning the probes, doing my M585 and reassigning them again. But this cant be the final solution.

    
    ; Start Workaround for M585
    M558 K1 P5 C"nil"
    M558 K0 P5 C"nil"
    M558 K0 P5 C"!e0stop"
    
    M585 P0 S1 F50 Z-5.15  ; Probe BedSensor (Offset to Bed: 0.15mm)
    
    M558 K0 P5 C"nil"
    M558 K0 P5 C"!zprobe.in"   H5 R0.000 A30 B0 S0.01 F200 T2000  ; Setup the Z-Probe (switch, active high)
    M558 K1 P5 C"!e0stop"
    G31 P1000 X25.0 Y-13.0 Z0.830 S22.0 C0 H0
    ; End Workaround for M585
    
    


  • And... I think that workaround will only work for Z???


Log in to reply