Can't reach Web Control but Duet Wifi is connected



  • Dear all,

    I just build my printer and configured the Duet Wifi for my local network.
    I have updated the firmware to 2.02 and the WifiServer to 1.23.

    The IP address assigned by the router is 192.168.0.124 but when I try to access the IP address it times out.
    I found on another topic in the forum to use the M111 S1 P1 and M111 S1 P2.
    When connecting from Firefox, YAT shows the following:

    Debugging enabled for modules: Network(1) Webserver(2)<LF>Debugging disabled for modules: Platform(0) GCodes(3) Move(4) Heat(5) DDA(6) Roland(7) Scanner(8) PrintMonitor(9) Storage(10) PortControl(11) DuetExpansion(12) FilamentSensors(13) WiFi(14) Display(15)<LF>ok<LF>New conn on socket 0 for local port 80<LF>HTTP connection accepted<LF>Found responder<LF>New conn on socket 0 for local port 80<LF>HTTP connection accepted<LF>Found responder<LF>New conn on socket 1 for local port 80<LF>HTTP connection accepted<LF>Found responder<LF>New conn on socket 0 for local port 80<LF>HTTP connection accepted<LF>

    But it does not show the Web Control.
    Does anyone know what could be the issue?

    Thanks,
    Melvin



  • Can you ping that IP address?



  • Looks like the connection gets through. The common problem is missing /www files or firmware missmatches - a timeout should be something else methinks.

    After verifying ping works, try enabling telnet and/or ftp and see if thats any better. (or if you don't have the Duet Web Control files in /www then...)


  • Moderator

    @MelvinN said in Can't reach Web Control but Duet Wifi is connected:

    I have updated the firmware to 2.02 and the WifiServer to 1.23.

    How did you update? Did you also update the DWC files? Why only to 2.02? Why not 2.05?



  • @Phaedrux I have found what I did wrong with updating. I updated the firmware to 2.05 but I am still having the same issues.



  • @Danal I could ping the address just fine but when I look for the IP address in Firefox, Edge or Internet Explorer it just doesn't show.



  • I downloaded the files from github, replaced the original files in /sys and checked if the names were correct.
    Then I ran M997 s0 and M997 s1 to update the Duet firmware and the web server.

    Just to be sure I deleted the /www folder, made a new folder /www on the SD card and extracted all the files from the DuetWebControl-SD-2.04 on to the SD card.

    Unfortunately it still doesn't work...


  • Moderator

    Try chrome?



  • @Phaedrux I tried Chrome but it also didn't work.
    I changed to another wifi network and now it works. Maybe the signal wasn't strong enough but both my laptop and phone didn't have any problems with it.
    Thanks for the help!
    And for all the best wishes for 2020


  • Moderator

    If you send M122 it will report a diagnostic. Near the end it shows wifi information including the signal strength.


Log in to reply