BLTouch cant set z offset with G31



  • Hello, i am trying to set the Z-offset with G31 but nothing happends whatever i set the Z to, it always starts printing about 2mm above the bed.

    This is the probe part of my config.g

    M574 X1 Y1 S1                         ; Set active high endstops (disable Z when using Bltouch)
    M574 Z1 S2 ; Define Z to use Probe. Home to Min.
    M307 H3 A-1 C-1 D-1 ; Disable the 3th Heater to free up PWM channel 5 on the Duex board.
    G31 P25 X-34.64 Y10 Z2 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    M557 X5:205 Y5:165 S20 ; Define mesh grid
    M558 P9 H5 F500 T4000 X0 Y0 Z1 ; Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves. BLtouch
    
    M557 X35:240 Y0:220 S34:36 ; define mesh grid
    

    What am i missing?



  • G31 must come after M558


Log in to reply