Motors not working after upgrade



  • Hello.

    I upgraded to firmware 2.05 about 2 weeks ago or so. After doing so, nothing happens when I try to move a motor. At first there were some errors about phases, but now nothing at all. The wiring did not change at all, and I'm sure I have the phases correct. After sending a move command, nothing errors out, and the system message at the top will say "Busy" for a moment, then it will report the axis position as moved that amount. I.E. I press x+10 after boot up, and x position reads 10, but no move. If I try to manually turn the motor after making the move, it spins freely.

    Now, the odd part: All heaters, fans, and thermistors are still functioning 100% correctly. Even the ir sensor and endstop leds will still go red and report that it is triggered. I have checked all fuses, however my Duet Wifi 2 is an older model when they were soldered on. 5v and 3.3v rails all show as working properly under my multi-meter.

    So I went back to the 2.02RC6 that was on it originally before all this. I unplugged all drives, plugged in only 1 to drive 2 which is set at X in my firmware, powered the duet back on, and tried to run it. Still nada.
    M122 Reports the following:

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02RC6(RTOS) running on Duet WiFi 1.0 or 1.01
    Board ID: 08DAM-999TL-MQ4S8-6JTD0-3SJ6L-14BMW
    Used output buffers: 3 of 20 (9 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98508 of which 0 recycled
    Exception stack ram used: 392
    Never used ram: 6648
    Tasks: NETWORK(ready,648) HEAT(blocked,848) MAIN(running,3804) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:05:16 ago, cause: power up
    Last software reset at 2019-12-12 01:30, reason: User, spinning module GCodes, available RAM 6648 bytes (slot 2)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 35.9, current 39.9, max 40.1
    Supply voltage: min 12.3, current 12.4, max 12.5, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max 0/0
    Driver 1: standstill, SG min/max 0/0
    Driver 2: standstill, SG min/max 0/1023
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-01-03 23:17:10
    Cache data hit count 1166347818
    Slowest loop: 3.96ms; fastest: 0.07ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 239, MaxWait: 159273ms, Underruns: 0, 0
    Scheduled moves: 21, completed moves: 21
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 15.79ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address xxxxxxxxxxxxxxx
      WiFi Vcc 3.38, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 25936
      WiFi IP address 192.168.254.75
      WiFi signal strength -41dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0

    I tried a breakout and a bare ramps board from the expansion header and the same, so decided to scope it. No signals are going out for en, step or dir from any pin on the board.

    Since I have tried upgrading on to 3.0. No go still. I know it's way out of warranty as I bought it in 2017, however this board only had about 50 - 60 hours of total print time (Was on my Mono Maker Select v2). Anything else I can try, or test to see if it is a single driver being bad? I have used the multi-meter and verified no voltage is coming from any pin when I tell a motor to move using the test pads on the board.

    I do have access to a 4 channel Rigol scope at home, and a nice Keysight one at work if I need to scope anything.


  • administrators

    Are there any error or warning messages when you try to move the axes? If the printer hasn't been homed then only G1 H1 and G1 H2 moves are allowed. So send G91 to select relative movement, then test the motors individually using G1 H2 X10, G1 H2 Y10 and so on.

    The most common cause of motors not moving is configuration errors, or config.g not being read. Send the following commands without parameters and check that the values returned are as expected:

    M584
    M906
    M913

    Also please post your config.g file.


Log in to reply