Z Probe offset not being applied



  • Tearing my hair out here ( the bit i have left anyway) just changed to RRF3 and everything is working well, exept that I cannot get the zprobe offset to apply. I can print perfectly if I set the z=0 height manually. I am using an NPN probe connected via an optocoupler to zprobe and ground my config.g is:

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards Z1
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S0 ; Drive 2 goes backwards Z2
    M584 X0 Y1 Z2:4 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation

    ;Steps and speeds
    M92 X200.00 Y200.00 Z1600.00 E866.00 ; set steps per mm
    M566 X2280.00 Y2280.00 Z600.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z300.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X2000.00 Y2000.00 Z350.00 E3000.00 ; set accelerations (mm/s^2) JERK
    M906 X1300 Y1300 Z1400 E1300 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X5 Y5 Z0 S1 ; set axis minima
    M208 X270 Y260 Z265 S0 ; set axis maxima
    M671 X-50:325 Y110:110 S4 ; Leadscrew positions for bed tramming(G32)

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-low endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M558 P8 C"^zprobe.in" H5 F400 T6000 ; set Z probe type to unfiltered(8) and the dive height + speeds (inductive probe via optocoupler)
    G31 P500 X-45 Y-35 Z2.23 ; set Z probe trigger value, offset and trigger height
    M557 X5:225 Y5:225 S40 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit
    M308 S1 P"e0temp" Y"pt1000" R4700 ; configure sensor 1 as PT1000 on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for the nozzle heater and set PWM limit

    ;Auto Tuning
    M307 H0 A132.3 C641.8 D0.3 S1.00 V13.7 B0 ; bed heater
    ;M307 H1 A724.1 C239.4 D9.1 S1.00 V14.0 B0 ; hot end
    M307 H1 A411.9 C143.7 D6.9 S1.00 V14.0 B0 ;Autotune after fault

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan1" Q500 ; create fan 2 on pin fan1 and set its frequency
    M106 P2 S1 H1 T45 ; set fan 2 value. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hot End1" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    T0 ;Select first(only) tool

    and my homeall.g is:
    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Mon Dec 30 2019 13:21:17 GMT+0000 (Greenwich Mean Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-265 Y-225 F3000 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-265 Y-225 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 X140 Y110 F6000 ;MOVE TO BED CENTRE
    G1 H1 Z-285 F360 ; move Z down stopping at the endstop
    G90 ; absolute positioning
    ;G92 Z0 ; set Z position to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    G91 ; relative positioning
    G1 H2 Z5 F1000 ; lift Z relative to current position
    G90 ; absolute positioning

    I've run out of ideas as to why but every print starts 2mm high ( same as my zprobe vertical offset). I can do bed tramming, which works (checked with a calipers) and a bed mesh. I've tried with and without mesh bed compensation
    Pretty sure I'm missing something here, but I just cant see it


  • Moderator

    @stewwy said in Z Probe offset not being applied:

    G1 H1 Z-285 F360 ; move Z down stopping at the endstop

    Your homing file isn't using the probe. You need to use G30 to probe the bed.



  • Thanks, that did it.
    I knew it was something stupid, I just couldn't see it 🙂


Log in to reply