Hotend Fan Turns off at start of print



  • Hi all.

    So I've been slowly getting my rostock back together and working with a duet2 wifi board and smart effector. I think I'm finally just about there, but I'm having issues getting the hotend fan to work correctly. As of right now, I have it wired correctly at the effector and running to the fan0 connection on the Duet2 WIFI. I also have it set to turn on at 100% when the hotend reaches 45C. This works exactly like it should. The problem starts when it goes to actually print. As soon as it finishes probing and begins to extrude filament the hotend fan will shutoff. Obviously this has let to more than one jam on me as I've been trying to figure this out.

    I also don't believe it to be related to the slicer. I've used both simplify3d and cura. The only start Gcode I use in the slicers is literally:

    G32
    G29

    At the moment I'm not running a print fan (long story, but basically I'm waiting on a berd airpump because I haven't been happy with anyof the other print fan solutions I've seen).

    Here's my current config.g file. Am I just missing something super simple here or is it other issues? Any help would be great! Thanks.

         ; set Z probe trigger value, offset and trigger height
    M557 R135 S40                                ; define mesh grid
    
    ; Heaters
    
    M307 H0 B0                            	     ; enable bang-bang mode for the bed heater and set PWM limit
    M305 P0 X201                                 ; configure PT100 for heater 1
    M143 H0 S120                                 ; set temperature limit for heater 1 to 120C
    M305 P1 X200                                 ; configure PT100 for heater 2
    M143 H1 S310                                 ; set temperature limit for heater 2 to 310C
    
    ; Fans
    M106 P0 C"Hotend Fan" S1 I0 F500 H2:2:1 T45   ; set fan 0 name, value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 C"Print Fan" S0.6 I0 F500 H-1        ; set fan 1 name, value, PWM signal inversion and frequency. Thermostatic control is turned off
    
    ; Tools
    M563 P0 S"e3D V6" D0 H1 F0                   ; define tool 0
    G10 P0 X0 Y0 Z0                              ; set tool 0 axis offsets
    G10 P0 R0 S0                                 ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M501                                         ; load saved parameters from non-volatile memory
    
    
    


  • @Metallikahn said in Hotend Fan Turns off at start of print:

    M106 P0 C"Hotend Fan" S1 I0 F500 H2:2:1 T45 ; set fan 0 name, value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 C"Print Fan" S0.6 I0 F500 H-1 ; set fan 1 name, value, PWM signal inversion and frequency.

    Typically the Fan0 port is used for the part cooling fan since the slicer is likely only using basic M106 and M107 to turn the fan on and off. Since you have them reverse, the slicer is probably sending a command to turn off the fans for the first layer.

    I suggest you swap the hotend fan to use fan1 and have it thermostatically controlled, and use Fan0 for the part cooling fan so the slicer can control it more easily. You'll just need to swap your fan definitions between P0 and P1 in your config as well.



  • Bingo! That was it. Not sure how I got those switched around on the board, but I did. I swapped the pins and then swapped the P0/P1 designations in the config.g and now it's working like it's suppose to.

    Only Oddity I see now is that in web control it gives a separate fan control (tool fan) that appears whenever the extruder heater is engaged. As far as I can tell it's a copy of the print fan control, seeing as how they will mirror each other whenever either one is changed. Anyway to set it in the tool settings so it just identifies it as the "print fan" instead of creating a whole new useless fan control?



  • Tool fan is exactly that, the fan attached to the currently selected tool. In a single tool printer it seems superfluous, but in a multi-tool setup it makes a lot more sense. Just ignore it.



  • Right on. Figured it'd be handy for a dual extrution, Just wanted to make sure I didn't have something set wrong there as well for regular single extrution set up.

    Thanks a ton for the Quick responses, btw. Really helped me out! 🙂


Log in to reply