Duet maestro cant connect to Duet Web Control............



  • So I've got an original duet maestro board and I dont know what to do to connect to the Web Control. I have never used a duet board until now. If you need extra info, please tell me. When I kinda connect to the Web Control, all I see is a messed up page that doesnt work. Im really frustrated at this point and I dont know how to fix this. I will include some images of what the page looks like. It sometimes times out as well.
    Thanks for the help!
    f.PNG duet web controll.PNG ff.PNG



  • Here's a series of guides for getting started with the Duet Maestro.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+1:+Wiring/37

    Though it looks like you are able to connect, things just aren't loading completely?

    What firmware version is installed?
    Are you able to ping the Maestro?
    Have you tried a different browser?



  • @Phaedrux

    I've tried chrome and i get the exact same results, edge doesnt load, firefox is messed up but kinda loads like in chrome.

    In YAT it says that the firmware is 2.0 ? I installed the newest firmware on github. I also used M21 to make sure the SD was connected. I downloaded DuetMaestroFirmware.bin and opened the SD and put it directly in sys file on the SD card. I also replaced the config files with one that I configured for a custom delta printer. The contents in the www file is also replaced with the new version of the files.

    Is M115 used to ping? because thats what i did as you can see in the images.

    The DWC is not loading fully and nothing on the page is functional (the buttons).

    Thanks!



  • M115 will return the current firmware version.

    When you placed the firmware bin file in the system folder did you then send the firmware update command as well?

    When you replaced the contents of the /www folder did you remove the existing files? Can you post an image of the directory structure to verify that the right files are in the right places?

    How are you powering the board?



  • m.PNG fware.PNG DW.PNG

    Hi its the same guy, i had to make a new account cus i got flagged as spam lol. sorry bout that



  • Ok, files look correct.

    The firmware version shows that it hasn't been updated yet.

    It looks like you're basically at the same point as this step of the guide.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+2:+Configuration/38#s137

    If you follow along from there it should allow you to update the firmware and hopefully get connected.

    As for the spam thing, new accounts are more tightly throttled. You probably won't be able to post multiple times within a few minutes. So you'll just have to be patient for the first while and let your account age a bit. It may be better even to continue to use your old account since it already has a few posts.



  • one more thing, i didnt send any kind of command for the firmware update, all i did was put the .bin file in the SD cards sys file.

    I did remove the old files and replaced them with new ones, as you can see from the date of the files in the images.



  • You might be missing the iap4e.bin file as well.

    Then you'll need to send M997 S0 to update the firmware.

    Follow through the guide linked above. It'll step you through first connection.



  • thanks for your time and help, ill follow the guide. hope i dont run in any trouble..
    cheers!



  • @Phaedrux

    ayyyy

    it worked dude!!

    Thanks a lot for helping me getting this up and running!

    nice!!!.PNG


Log in to reply