RRF3 and filament monitors



  • Hopefully the last bit on my RRF3 upgrade:
    In 'RepRapFirmware 3 overview', under M591, the new code example states:
    M591 P3 "e0_stop" S1
    On the Duet2 pin assignments there is no such thing as e0_stop but there is e0stop (without the '_')
    Which version is correct ?
    Under the gcode reference, there is 'D' parameter for the drive that is being monitored yet the example does not show a 'D' parameter ?

    This is the filament sensor section in my config.g file:
    ; set up filament sensors
    M591 D0 P1 C"e0stop" S1 ; enable (S1) filament sensor (normal switch) on Extruder 0 , connected to E0 sensor
    M591 D1 P1 C"e1stop" S1 ; enable (S1) filament sensor (normal switch) on Extruder 1 , connected to E1 sensor

    Neither one of these filament sensors changes with or without filament present.
    Any idea as to what I am doing wrong ?



  • As just found out when doing an M122, the filament out sensors seem to be working but under 'settings''machine-specific' the table with endstops shows all endstops being inactive (one should be active as filament is preset)
    Am I interpreting the 'endstops' table wrong .... does it just apply to actual end stops and not filament sensors ?
    Is there a separate view that tells me what the filament sensors are doing ?



  • I believe "M591 D0" with no other parameters will tell you both the configuration and the current status.



  • Thank you! Yes, that works perfectly and reflects the actual state of filaments. So the next question would be "is there anything on the web panel that shows me the filament status?" since the endstop table does not reflect reality as far as filament sensors is concerned (it does reflect me triggering an actual end stop)
    In any case, it's great to know that the filament sensors are working !



  • Not that I know of...

    It looks like endstops are in the table on "machine specific" page, but probes & filament monitors must be queried by command. At least for now.



  • Thanks for letting me know.


Log in to reply