Problems with mini height z probe



  • I'm installing a mini height sensor on a duet 0.85. It flashes twice on start-up but I've put M558 P2 in my config file. The red led lights up when it goes close to the bed and goes off as the z axis moves up. I then send G31 and no matter what height I move the z axis too , I get zero appearing on the web interface regardless of if the red led is on or not. Do you think I may have a faulty sensor?


  • administrators

    Use M558 P1, not P2.



  • I've been using the mini ir module for a while now…on a modified ormerod 2
    now i'm building another and i got another module ...this time its not working i'm using the same config

    with M558 P1
    and then G31
    i know the module boots up as it flashes red 4 times .....then its not responsive, no red light no triggering the value is zero
    so i tried another mode and it flashed twice... then checked my duet with the original ir sensor that came with the ormerod 2
    and its working so my pins are fine.
    i run ponterface, don't have a web interface cuz i had a faulty hanrun rj42 which kept giving me the AJAX and so i de-soldered it
    (hey question, it was a HanRun14/10 so should i use the same thing or can i go for some other version of the HanRun like the 10/25 or 12/18)
    anyhow checked the connections
    on AD12 its all good
    config
    https://www.dropbox.com/s/wsjlaoz868koepj/config.g?dl=0



  • that link is dead, this is the config https://www.dropbox.com/s/mfg33prg3qxu62j/config.g?dl=0

    anyone..


  • administrators

    Does the red LED on the sensor come on when you put your finger under the sensor? If it doesn't, ask for a replacement.



  • it doesn't.. 😞



  • thanks david…. i will, but i still want to figure out whats causing it. ill get back with updates


Log in to reply