RRF3.0 & z-probe



  • Hi,

    After switching to RRF3.0, I can no longer do automatic G32 calibration:

    1/ the z-probe measurement is no longer on the web interface ( => it can be displayed with the parameter "return to DWC1")
    2/ when I launch G32 , it launches a "manual" z-probe, and not automatic !

    My config in config.g :
    ;
    ; ***** Z probe and compensation definition *****
    M558 P1 F100 T3000 X0 Y0 Z0 H4 ; Z probe is a Smart Effector
    G31 P500 X0 Y0 Z1.80 ; Set the zprobe height and threshold for Smart Effector
    M557 R85 S20 ; define mesh grid
    ;

    My config in bed.g :
    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G28
    G30 P0 X0.00 Y80.00 Z-99999 H0
    .......................
    G30 P15 X0 Y0 Z-99999 S6
    ;
    G1 X0 Y0 Z150 F6000 ; get the head out of the way of the bed
    ;
    M500 ;
    G29

    Anything changed about the G32 calibration?

    Thanks.

    Ludis


  • administrators

    @ludisnet said in RRF3.0 & z-probe:

    M558 P1 F100 T3000 X0 Y0 Z0 H4 ; Z probe is a Smart Effector

    Add the pin name of the Z probe to the M558 command. Also you should use P8 for Smart Effector, not P1, and a higher probing speed. This is what I use on my delta, with Duet WiFi with RRF 3.01beta1:

    M558 P8 C"zprobe.in+zprobe.mod" H4 F1000 T12000 R0.2 S0.02 A5
    G31 X0 Y0 Z-0.10 P100



  • @dc42 : Thanks, G32 work well now.

    Now, I wanted to make a G29 (I discover...), and after launching G29, in the middle of the bed, it displays an error:
    "
    G29
    Error: Z probe already triggered before probing move started
    "

    Do you know why?

    my parameter in config.g :
    M557 R85 S20 ; define mesh grid

    In the GUI, the M557 setting parameters (...define zone) do not take over the values from config.g ...what to do?
    62ba2ab1-38b5-4b35-9a6e-265b90ce8c7e-image.png

    Thank you.

    PS : delta, with bed radius ~100cm



  • so, i reduce speed (z-probe), and work without error ....
    with :
    M558 P8 C"zprobe.in+zprobe.mod" H4 F500 T8000 ; R0.2 S0.02 A5

    Ludis


  • administrators

    @ludisnet said in RRF3.0 & z-probe:

    so, i reduce speed (z-probe), and work without error ....
    with :
    M558 P8 C"zprobe.in+zprobe.mod" H4 F500 T8000 ; R0.2 S0.02 A5

    Ludis

    You could increase the R parameter, to allow the effector more time to settle before probing starts.


Log in to reply