having issues connecting to Duwifi



  • Everything has been working wonderfully, but as always, the grimlins were just around the corner. Someone got hold of me network SSID we think so I had to change it and that has been a night mare...computers, laptops, ipads, phones, tv, security ...the list goes on. Now I can connect to everything except the Duet wifi. It just acts like it can't find the network even though I added the correct correct SSID and password (checked it many times). I am posting my config.g (minues the SSID and password) below. Can anyone see a reason this/ would not work? Is there something else I need to do besides changing the config.g when changing the SSID?

    Thanks for any help you can give.
    Charlie
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri Feb 01 2019 16:04:24 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"Core XY" ; Set machine name
    M552 S1 ; Enable network

    M587 S"xxxxxxxxxx" P"xxxxxxxxxxxxxxx" ; Configure access point

    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation

    M92 X80.5369 Y100.7067 Z399.9219 E416.666 ; Set steps per mm

    M566 X900.00 Y900.00 Z150.00 E857.1428 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y6000.00 Z380.00 E1500.00 ; Set maximum speeds (mm/min)
    M201 X3000.00 Y500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X950.00 Y950.00 Z950.00 E950.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y270 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    ;M574 Z1 S2 ; Set endstops controlled by probe
    ;M558 P5 H5 F0 T6000 ; Set Z probe type to switch and the dive height + speeds
    ;G31 P500 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    ;M557 X15:13 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C

    M305 P1 T100000 B4725 C7.06e-8 R4700 ; as suggested by Phaedrux
    ;M305 P1 T100000 B4388 C7.06e-8 R4700 ; As suggested by mudcurxzr
    ;M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1

    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H2 S280

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Attempt to control heater2
    M307 H2 A-1 C-1 D-1 ; Disable Heater E1 for use with the Berd-Air cooling
    M106 P0 A2 S0 F30000 ; Fan 0 (Part Cooler) using Heater E1 Mosfet; Custom settings are not configured

    ; BLTouch code
    M557 X30:290 Y30:290 S112
    G29 S
    M307 H3 A-1 C-1 D-1
    M558 P9 H5 F100 T2000
    G31 X30 Y15 Z3 P25
    ;G31 P500 Z1
    G31 P500 Z4.58
    M375 ; load "heightMape.csv"



  • SSIDs are stored in flash memory on the WiFi sub-module. For this reason, leaving M587 in your config.g is a bad idea... it re-flashes every time you boot and will eventually wear out the flash on the WiFi module.

    Anyway, your real problem is likely to be that your old SSID is still in the WiFi flash. Therefore, do the following (via the USB port):

    M522 S0 ; Put WiFi module in idle mode
    M588 S"*" ; Delete all saved networks in WiFi module flash.
    M587 S"xxxxxxxxxx" P"xxxxxxxxxxxxxxx" ; Configure access point

    Then M522 S1 and see if it connects. Once you have this working via USB, be sure and delete any/all M587 from Config.G.



  • I will do this tomorrow. Thank you very much. I had a feeling it was something like this.

    Charlie

    I will let you know what happens when I do this.
    Thanks again.



  • I assume you would use YAT or something of that ilk, right?



  • unfortunately, I have not done much with the terminal and Duet.
    I am using YAT and when I hook up the USB to my laptop, the will power up even if the p/s is not running. I am not sure if the p/s needs to be on for this, but in ether case output looks like this:

    M522 S0;
    M522 command is not supported<LF>ok<LF>
    M522 S0;
    M522 command is not supported<LF>ok<LF>

    the port is set to 9600, 8, none, 1 I have
    to assume that the Duet is able to recieve ok since the message above would indicate it understood what I sent.

    Sorry if these are a bit rudimentary problems. These days, I seem to be a rudimentary kind of guy.



  • Ahaa ! Success. I little investigating m codes, I realized what you meant was M552 rather than M522. Made the change, ran the commands and it attached as it should.

    Thank you very much



  • Excellent! Sorry about the typo...


Log in to reply