DUET 3 stealthchop noise and a possible fix



  • I too, noticed stealthchop on my duet 3 was as noisy as spreadcycle, as if it wasn't being engaged. With all the M569 tweaks I couldn't get any improvement. That sucked because I went to this board to try and run a bit more quietly, like my other printers with stealthchop.

    I read the datasheet and saw that some TCOOLTHRS register thingy can disable stealthchop, so I had a looksee in the code and saw that it was controlled with the M915

    Sent in these commands to my 2 z axis drivers, (as a guess) not sure the correct T value to send
    M915 P0.2 S3 R0 T1
    M915 P0.3 S3 R0 T1

    And nowww they sound quiet. Not sure what threshold T1 amounts to, but for once it became quiet.
    If they go too fast they make horrible noises, guess I need to turn that spreadcycle switch threshold back to a reasonable level?
    Hope this helps someone or dc42 can expand on what to actually do.



  • I'm getting the same thing as you and same confusion about the noise.

    What speeds are you printing at?
    Did you adjust the V parameter at all in M569?
    At what speeds do they make the terrible noise?

    I must be doing something differently, since these commands do nothing for me 🙂
    I can only get silence at speeds sub 5mm/s.


  • administrators

    Thanks. I already made changes in the forthcoming 3.01RC2 release to take account of the need to change TCOOLTHRS when enabling stealthChop.


Log in to reply