Duet Wifi 1.0, noisy sensor values



  • Yesterday I went to visit a machine shop owner to solve a few network troubles. One of the issues was a delta printer powered by a Duet Wifi 1.0 that was unreachable over the network. That was network related and solved. Next issue was that the Duet lost it's Wifi connection every 20 seconds or so despite being quite close to the access point and good RSSI (-58dBm). It was running very old firmware (1.18 or so) and an equally old Wifi server.

    I decided to upgrade the board to more recent firmwares before troubleshooting the Wifi connection. This failed; uploading the files through DWC worked for the Wifiserver, not for DWC and the main firmware. Renaming the Duet2CombinedFirmware.bin to DuetWifiFirmware.bin and starting the upgrade process through the terminal left me with a completely unresponsive Duet Wifi with the diag led on, which I could only recover using BOSSA. Oh well, now it runs the latest RRF2 and DWC, and the Wifi issues are gone.

    But there is another issue: there are a lot of spikes, steps and noise on the thermistor inputs. Both the bed and hotend. Steps are 20C or so, noise is 10C. You can autotune whatever you like, trying to set a temperature after that always results in a heater fault.
    Also, the hotend temp graph flattens out around 235C, but the hotend seems to heat up much further than that.

    The printer used to work, both sensors have issues, so it has a common cause. Spikes and steps do not happen at the same time on both heaters so the common cause is likely not the ADC reference. And since it used to work (they showed parts made on that machine) I do suspect the RRF1.xx -> RRF2 update.

    Could a firmware update (flashed through BOSSA, if that makes a difference) cause this behaviour?


  • Moderator

    @DaBit Were there spikes when it was running RRF1.18? Do the spikes on bed and hot end happen at the same time? Put a 100k resistor on the bed and hot end temp pins on the board, and see if it still spikes. Could be a noisy/failing 3.3V regulator (the temp sensors are all run from a common 3.3V supply), or PSU related problem. Otherwise, perhaps dirt/shorting on the PCB, or (as it's quite an old board) a dry solder joint somewhere. I've never seen this behaviour due to a firmware update.

    Ian



  • Not sure.

    In hindsight I should have tried a test print in original configuration and verify the working of everything before updating, but since the Wifi connection was so utterly unreliable and no simple print such as a calibration cube was amongst the jobs on the SD card it would have taken too much time on an evening. There were successful prints on the desk next to the printer though.

    I could have verified by flashing back to 1.18 and restoring a backup of the SD (which I did make), but it was already quite late (or early, depending on the point of view...) and I was done with it. Maybe I will try that later.


  • administrators

    I don't remember anyone else reporting temperature spikes immediately after changing firmware version. They could be caused by:

    • Bad connections
    • Leakage between the bed heater and bed thermistor (possibly via the bed plate), or between the extruder heater and extruder thermistor (possibly via the extruder metalwork)
    • Overloading of the 3.3V power rail causing it to be unstable
    • Bad soldering of the VSSA fuse to the Duet PCB


  • So, conclusion: firmware update is very unlikely to cause this. Nice, I don't really want to try running RRF1 again given the nightmare the upgrade turned out to be yesterday.

    I will see how this develops. If they cannot figure it out they can bring the printer to me and I will do some more debugging. Until that time I simply have no physical access to that machine.


Log in to reply