Odd motion issues

  • Of course I did that thing you're not supposed to - I made two changes at once. Change one was to replace my belts and one stepper, and just tighten things up. No major parts or pieces changes (I was chasing down a rattling noise in my printer).

    Change two was to upgrade to firmware 1.18

    So, that said, I'm fighting a weird motion issue. I see it in a couple of ways:

    1 - When I do a z-probe, I have a 1 second pause (R1) in my M558 as follows: M558 P1 I0 F200 X0 Y0 Z0 T3000 R1 When it's done with the pause, and the nozzle does its dive to probe, I can see it jog slightly horizontally before it descends to tap the bed. (I can try and get a video if needed, we're talking maybe one step on the stepper of movement). It's most noticeable towards the X tower.

    2 - During a print, when it's moving the the X direction towards the front of the bed, the nozzle gets lower. When it's moving in Y, it's a tad too high. This is regardless of where on the bed it's printing. See here: http://imgur.com/nMRsJ3Z In that picture, the part is oriented so the face on the bottom right of the picture is towards the front of my bed (the photo is from the X tower looking in at the print).

    It would appear one of two things is going on that I can think of:
    1 - I have backlash. I checked all the grub screws on my steppers, and can't find anything loose. I'm not ruling it out, though.
    2 - I have some sort of motion problem. It almost looks like one stepper is lagging slightly behind the others, or getting slightly ahead… I'm not sure.

    Any suggestions? I haven't tried rolling back to 1.17 yet, wanted to ask and see if there was a case where someone had seen this before and could offer insight. I'm rather stumped.

    This is a rostock max v2 based printer, Carbon Fiber magball arms (The Haydn delrin ones). Can provide config or other info as needed. (Steps/mm is set to 80 for all 3 towers... seems the most relevant item)

  • Not sure what it is but I've noticed since 1.18 that after I calibrate my delta I set a G1 Z5, then a G30 (without any parameters) to re-zero the z level (this is something I've been playing with, with the piezo probe to see if you can essentially set a first layer gap using a very sensitive probe). My last probing point in the bed.g is bed centre, but there is a slight horizontal move which takes place before it dives for the G30 single probe. I asked David if the firmware was being clever and zeroing on a grid corner for the G30 but he confirmed that it is not. Related? Not sure.

    The other issue I had which was a saga was belt related; steel cored belts stretching, causing a skewed tower to print but go straight after 65mm which was very hard to diagnose. You mentioned changing belts, did you give them a once over and/or stretch test before fitting them?

    I documented it here: http://forums.reprap.org/read.php?178,731246
    Try a few things from that post like switching all the motors and endstops around clockwise and seeing what happens. Lift the bed to a different level, if possible and recalibrate and try again, this is what solved it for me, with the bed at 70mm above normal everything printed straight.

  • Changing the belts didn't change this behavior at all. (Though the weird noise went away, so that's a plus)

    In that picture, the oddest thing to me is that in the closest corner you can see that as soon as it hits the mid-point of the curve on the skirt, the nozzle picks up and it changes from way too low to printing too high. That's the real puzzler for me.

    I put a new stepper in the Y tower, made no difference. I moved the Y stepper to the Z tower, no difference. I can put the old Z tower in the X tower next… that will effectively accomplish moving all the steppers around.

    I haven't tried moving my endstops yet.

  • That horizontal move you describe on probing is exactly what I see, too. I have no idea if it's related to the changing layer heights during my prints. I really didn't want to have to downgrade to 1.17, downgrading never seems to go well for me, but I may have to try it and see.

  • Swapped arm pairs between the towers, and also tried rotating my effector. No difference from either.

  • I was suggesting rotating all the motors and endstops to rule out a motor/driver issue but it seems you've practically done it already.

    Are you using grid levelling? I vaguely recall the issue with the move on probing was related to switching the grid off before the probing moves or something along those lines.

  • No grid levelling currently. I've run it in the past, but I've deleted the heatmap file and am not running a G29. Just doing an S6 calibration, 16 probe points.

  • administrators

    Regarding the horizontal movement before probing, are any of you using orthogonal axis compensation (M556)? Compensation is now disabled during probing moves, and that might account for a small horizontal movement.

  • No I'm not using m556. Although I just tried this and it did not make the horizontal move.Although I am calibrating to around 0.02, maybe it does it if the calibration comes back a lot further off?

  • No m556 here either. I calibrate into the 0.025 range currently.

  • I think I'm going to bite the bullet and go back to 1.17 today. Pretty sure the only firmware changes I made were on my z-probe offset, and my PID tuning, and I saved all of that. Hopefully the downgrade goes well.

  • Trying to figure out what all I need to downgrade when going back to 1.17e

    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.18.1 (2017-04-09)
    WiFi Server Version: 1.03 (ch fork)
    Web Interface Version: 1.15b

  • Downgraded to 1.17e, still the same kind of look going on. Not as severe, but that's more to do with the first layer thickness from the different probe offset, I think. So has to be mechanical, I guess.

    Now to try and think through the remainder of what could cause something like that.

  • Tore down all 3 towers last night (removed the bearings, steppers, carriages, belts) no signs of any issue in any of them. Rebuilt it, and same deal. I did retest for tilt using my gyro/accel, found a little and corrected for that. Cleaned up my calibration results a tad, but prints do the same thing. Even rotated my bed to see if it was just a high spot, but it stays in the same pattern, no change at all from that.

    The only other thing I can think of that changed recently is I made the newer mount for my piezo probe. It made the probe much more sensitive. My calibration is more precise, but I don't see why it would cause this behavior. So I'm rather stumped at the moment. I can increase the height of my first layer a bit and "hide" that, but it's obviously not an ideal solution.

  • administrators

    1. Are you running G32 or G29 when you get this behaviour during probing? If it's G32, please post your bed.g file.

    2. Do you have any M556 axis compensation configured in config.g?

  • I'm just hitting the Delta Auto-Calibration button to run bed.g - that's just a G32, right?

    Here's my bed.g (with a ton of comment lines removed…):

    M558 P1 I0 F200 X0 Y0 Z0 T3000 R1
    G31 X0 Y0 Z0.00 P325

    G1 Z5 F4500
    G1 X0.00 Y120.00 Z5 F4500
    G4 S1

    G30 P0 X0.00 Y120.00 Z-99999 H0
    G30 P1 X77.13 Y91.93 Z-99999 H0
    G30 P2 X118.18 Y20.84 Z-99999 H0
    G30 P3 X103.92 Y-60.00 Z-99999 H0
    G30 P4 X41.04 Y-112.76 Z-99999 H0
    G30 P5 X-41.04 Y-112.76 Z-99999 H0
    G30 P6 X-103.92 Y-60.00 Z-99999 H0
    G30 P7 X-118.18 Y20.84 Z-99999 H0
    G30 P8 X-77.13 Y91.93 Z-99999 H0
    G30 P9 X0.00 Y60.00 Z-99999 H0
    G30 P10 X51.96 Y30.00 Z-99999 H0
    G30 P11 X51.96 Y-30.00 Z-99999 H0
    G30 P12 X0.00 Y-60.00 Z-99999 H0
    G30 P13 X-51.96 Y-30.00 Z-99999 H0
    G30 P14 X-51.96 Y30.00 Z-99999 H0
    G30 P15 X0 Y0 Z-99999 S6


    This line is in my config.g... I don't remember putting it there, so it must be from the base config I started with and I forgot about it. Should I comment it out?

    M556 S78 X0 Y0 Z0 ; Axis compensation here

  • Just for kicks, here's the results of a G29:


    RepRapFirmware height map file v1 generated at 2017-04-05 11:27, mean error 0.00, deviation 0.03
    0, 0, 0, 0, 0, -0.043, -0.014, 0.037, 0, 0, 0, 0, 0
    0, 0, 0, -0.041, -0.036, -0.023, -0.012, 0.009, 0.031, 0.070, 0, 0, 0
    0, 0, -0.002, -0.040, -0.030, -0.012, 0.001, 0.036, 0.053, 0.057, 0.083, 0, 0
    0, 0.021, 0.032, -0.010, -0.007, -0.013, -0.010, 0.011, 0.002, -0.004, 0.027, 0.042, 0
    0, 0.012, -0.012, -0.010, -0.028, -0.010, 0.003, 0.023, 0.037, 0.022, 0.045, 0.032, 0
    0.051, 0.041, 0.029, 0.000, -0.003, -0.014, -0.016, -0.012, -0.012, -0.022, -0.002, -0.027, -0.029
    0.028, 0.008, 0.010, -0.023, -0.026, -0.003, -0.003, 0.008, 0.011, 0.015, -0.014, -0.015, -0.008
    0.024, 0.015, 0.013, -0.009, -0.002, -0.012, 0.001, 0.003, 0.000, -0.013, -0.027, -0.038, -0.053
    0, -0.028, -0.035, -0.027, -0.009, -0.005, 0.010, 0.010, 0.001, 0.021, 0.014, 0.003, 0
    0, -0.054, -0.033, -0.027, -0.024, -0.015, -0.003, -0.002, 0.002, 0.013, 0.001, 0.012, 0
    0, 0, -0.062, -0.038, -0.037, -0.021, 0.002, 0.004, 0.014, 0.027, 0.042, 0, 0
    0, 0, 0, -0.077, -0.039, -0.029, 0.011, 0.034, 0.061, 0.061, 0, 0, 0
    0, 0, 0, 0, 0, 0.008, 0.037, 0.058, 0, 0, 0, 0, 0

  • I think things are looking better. I took everything apart once again in all 3 towers. Stripped the belts, idlers, steppers, all of it.

    Found two possible things… one, my pulleys on my steppers weren't as well aligned as they could have been. Adjusted that, which cleaned up the belt path. (They weren't bad, just a tick off)

    The other is the Z stepper wiring was directly laying on top of my 12v PSU's output ports. Not sure it was definitely getting any interference, but it's probably something to avoid. The first layer looks better now, so it's promising that was it. Need to run through a few prints to see.

Log in to reply