Sannce camera not behaving as described in documentation



  • I got the Sannce I21AG camera since i say there were instructions in the documentation on how to connect it to my duet board. Well, when i tried to run down the steps from the doc i ran into multiple issues/things missing:

    • the seach tool does not work/find any entries (or i don't know how to use it, i have only a refresh and clean ARP button). I know it's IP since i found it in my router
    • tried getting its port via a portscanner but didn't find any open tcp ports, only udp (and browser doesn't work on them, tested out most of them)

    The camera works with the JoyLite App (both PC and Android version) but i would have liked to have the preview in the Duet interface.
    Can anybody please assist?



  • Which Browser do you use if Chrome I can give you my settings for you to modify for your situation.

    In fact here it is (the link is truncated to the left but you should get the idea.

    82bb70ad-fe17-444d-8153-6f9a55c5805e-image.png

    You will have to find the IP and the port yourself for your setup.

    Hope this helps a little.

    Doug



  • @Dougal1957 Unfortunately it does not help, as i was saying i cannot determine the port or at least do not know how. I got the ip, haven't got the username or password and the app does not give the me option to create a user or password.



  • can you view the stream from the camera in your browser outside of duet web control?



  • @bearer no, i cannot, only in sannce's app Joylite



  • @yonutz33 have you downloaded the app as specified in the documentation?

    Camera Details App

    running this should give you those options when I set mine up with the Sannce phone app I had to name the cam and give it a PW!

    also see https://support.sannce.com/hc/en-us/articles/360029333311-Sannce-Cam-How-to-use-IP-address-to-check-the-live-view



  • Hi,

    I tried to follow the guide you linked in the past and retried it now again and it doesn't work.
    Let me detail that for you, here's a screenshot of the Sannce Cam app used:
    Screenshot_20200208-142336.png

    • When using the last option as described in the guide (in my case Wireless Configuration Wifi not One Key Add), i choose Camera, then I input my Wifi info. Then it makes some high pitched noises and dispays a countdown timer from 60 while noting happens with the camera or app. After that timer is finished it displays Paired WiFi end, is searching device ... and then nothing. I've left it running up to 15 minutes with no change. I tried resetting the camera in various steps from the above, nothing.
    • I also tried with Search device in LAN, it doesn't find it
    • I tried with Scanning device QRcode, it completes the DID info. But after pushing the Done button and getting back to the view with list of cameras it displays an Invalid id below the camera name.

    The search tool returns nothing, i click refresh, nothing happens. I will make a test later today with a laptop using Windows 7, since their screenshots seem to be made from a Windows 7 PC. I am using a Windows 10 laptop at this time.

    Here's also a screenshot of the camera model and uid code, maybe it helps
    IMG_20200208_143235.jpg !



  • I will reach out to the Sannce Group maybe they can assist. I think they updated the firmware and changed the app without any notice to the users (wouldn't be the first time china manufacturers did this), so future buyers be warned!



  • Here is a Youtube video you can try. video
    When you try the wireless method you do keep the phone close to the camera?



  • @Synapsis said in Sannce camera not behaving as described in documentation:

    Here is a Youtube video you can try. video
    When you try the wireless method you do keep the phone close to the camera?

    I can connect using the new app, Joylite as described in the video. The problem is I cannot access it from my browser, so that i can include it in the duet web interface.


Log in to reply