RRF config tool not adding M915



  • Hi All,

    I ran the configuration wizard. Set the X and Y to sensorless homing.
    Reading through the G-code page, the M915 describes how to set the current to adjust the stall detection.
    But i don't see the M915 command mentioned, to adjust the Current in the Config.g file.

    These are my notes, to add it manually.
    *After M584
    M915 P0:1 S10 F1 R0 ; Stall detection sensorless homing (X and Y Current must be the same value)

    At the Endstops section
    M574 X1 Y2 S3 ; set Sensorless Homing with S3 was (Check value Sx)*

    So my question is,
    Can I trust the config tool to have written a good config file, and i do not have to enter the M915 line.
    OR
    Do I add the "M915 P0:1 S10 F1 R0" after the M584?

    Im confused 🙂

    wkr,
    Martijn


  • Moderator

    @Md3Man While you can set the axes to sensorless homing in the RRF config tool, you need to tune the sensorless homing for your setup. When Sensorless homing is selected in the config tool, it pops up the message (in blue) below the endstop configuration:

    0e65801c-6abf-45cd-bae9-7d7f559d7cdc-image.png
    See https://duet3d.dozuki.com/Wiki/Stall_detection_and_sensorless_homing for setting it up.

    Ian



  • Wow that is fast 🙂

    Yes that's how i came up with the question, i did exactly just that.
    Then i read about the M915 but did not see it in the Config.g file.
    So ill add the line manually as i put in my question.

    Thank you.


  • Moderator

    @Md3Man Sorry, yes, should have said that you need to add M915 to your config.g!

    Ian


Log in to reply