How to Control Part cooling Fan



  • I have the Duet2 Ethernet setup on my printer. I an now working on the start and end code to put in Cura. I am running the newest firmware 3.0. I have the Extruder fan plugged into FAN0 and part fan in FAN1.

    The Extruder fan will turn on and off when the hot end reaches the set temp. I usually do not want the part fan to turn on until the first layer is finished. I know I could set T to a large number at the start but how do I get this setup so Cura will turn it on after the first layer?

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H T60 ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T60 ; set fan 1 value. Thermostatic control is turned on


  • Moderator

    @Keith53 said in How to Control Part cooling Fan:

    M106 P1 S1 H1 T60 ; set fan 1 value. Thermostatic control is turned on

    Change H1 to H-1 to disable thermostatic control.

    Also, you've got an H but no 1 for fan0. It looks like it's defaulting to H1 anyway, but you may still want to correct it.

    M106 P0 S0 H T60 ; set fan 0 value. Thermostatic control is turned on



  • Thanks

    How do I setup Cura to post the Fan on after the first layer? Cura is putting in M107 and M106 S255


  • Moderator

    I believe you can specify the fan number in Cura in the printer settings.


Log in to reply