No access to Duet Wifi over serial/wireless



  • I just updated my Duet 2 to RRF3.0. Had a bit of trouble, but I was finally able to get everything up and going. That was like a week or two ago. Now I've just replaced my super old WiFi router with a new one and I cannot get my Duet to connect. The SSID and password are the same, so I'm not sure why the Duet is not able to connect to my network. I tried to connect via USB to rerun the wifi configuration stuff, but for whatever reason I cannot connect to my Duet over serial via YAT or Pronterface. No clue what the issue is, and I'm at a loss on what to do. Any ideas?

    Thank you in advanced!



  • When you plug the USB into a computer, does a serial port appear? You can plug and unplug several times and use "Device Manager" to see what comes and goes.

    Then, double check that that serial port is the one in YAT (or whatever terminal program you use).



  • @Danal Nope. Doesn't feel like the computer is recognizing that anything is plugged; however, the Duet is at least getting power over the USB because 5V comes on



  • Windows is pretty notorious for USB wierdness. Try different cables, different ports, etc. If you absolutely cannot get a serial port to appear, post back here.

    And... are you running a Pi? Or stand-alone?



  • @Danal Tried a couple different cables, and every individual port. Still nothing. Also, running the Duet standalone. No Pi connected



  • USB should show up, given three things:

    • No Pi
    • With or without an SD card, with or without /sys/config.g on that card, etc.
    • Firmware sitting in the 'flash' of the CPU that initializes the USB.

    Therefore, I think it is time to follow the steps here:

    https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond



  • @Danal Whew! Didn't have to do the erase procedure luckily. I was finally able to get connected over serial. For whatever reason, the Duet was ignoring an apostrophe in my SSID. Not sure why, but I just changed my network name on my router and was able to get connected again.

    Thanks!


  • Moderator

    @wcj97 said in No access to Duet Wifi over serial/wireless:

    apostrophe in my SSID

    The apostrophe is considered a special character in this case.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M587_Add_WiFi_host_network_to_remembered_list_or_list_remembered_networks

    Many programs used to send GCodes convert all characters to uppercase. In firmware 1.19.2 and later, within any quoted string you can use a single-quote character to indicate that the following character should be changed to lowercase. For example, M587 S"ABC" P"P'A'S'SW'O'R'D" would specify that the password is "PassWord". Use two single quote characters to represent one actual single quote character in the password or in the SSID. For example, if your SSID is "Pete's network" then enter "Pete''s network".


Log in to reply