Commissioning ...



  • I need to run an extruder in 'commissioning' mode - so I don't want nor care if a heater is present or doing what it is supposed to.

    This is commissioning and the ability to test rotation is a fundamental part of that process, the current commissioning documentation is also deficient as it doesn't mention the need to send M564 H0 to facilitate driving the Axis steppers.

    How do I disable the automatic enable of the heater if you try to drive the extruder, how can I prevent the extruder motion being disabled by a heater fault. The heaters will be the very last thing that I connect.



  • @Garfield said in Commissioning ...:

    How do I disable the automatic enable of the heater if you try to drive the extruder,

    Set desired temp, and standby temp, to 0. Web or Gcode.

    how can I prevent the extruder motion being disabled by a heater fault.

    You won't get faults with 0 temps.

    documentation is also deficient as it doesn't mention the need to send M564 H0 to facilitate driving the Axis steppers.

    One of the documents fixed; finding the others now.



  • Hi Danal.

    Not working, sensors showing negative -0.6 (PT100 with resistor in place currently).

    M109 doesn't seem to set -ve value, if U use DWC to set -1 the value 'appears' but the command G0 E10 still results in a 'cant be driven because the temperature is too low' - or words to that effect.



  • This doesn't work whether I use M109 or G10 same warning about heater not hot enough - except the target and standby are both -1 ...

    No fault is showing - resistor is creating the circuit.



  • Tested it on one of the axis drivers, and happy enough - but

    There really needs to be a way to bypass this nanny state stuff. It is all very well for the inexperienced but writing code to handle stupid is a slippery slope - there will always be better stupid.

    Sorry but there needs to be a way to bypass safety's ....



  • What board and firmware release? I just tried this on V2 and V3 and it works:

    DWC set active and standby to 0
    M564 H0
    G91
    G0 E5

    Extruder moves and no faults are shown.

    I don't have any easy way to get the temps to a negative -0.6. Perhaps unplug those boards?



  • My apologies... I had forgotten that "M564 H0" is "move without homing"

    To cold extrude, the command is "M302 P1"



  • That works (M301 P1) but it turns the heater on ....

    Duet 3 with whatever latest and greatest is, I haven't gone as far as RC1 yet (I don't think)

    Board: Duet 3 MB6HC (MB6HC)
    DSF Version: 1.2.4.0
    Firmware: RepRapFirmware for Duet 3 MB6HC v0.6 or 1.0 3.0 (2020-01-03b3)



  • @Garfield said in Commissioning ...:

    That works (M301 P1) but it turns the heater on ....

    The heater that is set to 0? Given the sensor is -0.6, you may need to unplug that sensor during commissioning (or get it to read room temperature).



  • Yup - tried setting it -1 but that seems to be ignored ...



  • Not -1. Zero.

    And, you may need to unplug that sensor during commissioning, or get it to read room temperature.



  • Resistor is currently around 97 ohms, I'll try removing it but I'm sure it goes to -273. I've tested what I need to now.

    Would be useful to include extruder commissioning in the commissioning docs, then comes the temperature commissioning and tuning ... who knows I may even get a print out before the end of Feb on the new box.

    I'm used to Marlin and Prusa's expertise, RepRap and building my own is new territory ...



  • @Garfield said in Commissioning ...:

    Resistor is currently around 97 ohms, I'll try removing it but I'm sure it goes to -273

    I believe I've commissioned with -273 before, and target of 0. About 99% certain... but I could be wrong.



  • Just tried it. unplugged sensor, -273.1, active and standby targets both 0.

    M302 P1
    G91
    G0 E10

    Extruder moves, no heater turned on. In fact, sensor shows "fault" and extruder still moves.



  • If I use that I get the error 'No tool selected'

    The second I use T0 to select the extruder the heater enables ...



  • Ah, yes, selecting the tool will definitely enable the heater. You can immediately turn it off in DWC. Just click on the heater itself (it will cycle through Active, Standby, Off).

    The heater can be off, and you can still move the extruder (after M301 P1). I just did that (and on a multi tool printer, as well)



  • I also selected the tool with the unplugged sensor, let the heater fault, reset it, turned it off, and then moved the extruder (with the three commands above)



  • Agreed, I can indeed cycle through or even turn it off, it isn't actually connected fortunately. If I'd had the heater connected and sitting on the desk or someplace else other than in the hot end it could have certainly made the evening more interesting.


  • administrators

    @Garfield said in Commissioning ...:

    The second I use T0 to select the extruder the heater enables ...

    Sounds like you have set an active temperature on it using G10. I suggest you post your config.g file so we can see what G10 commands you use in it.



  • Used G10 from the console in DWC

    G10 R-1 S-1
    T0

    As the sensor was showing -0.6, the negatives seem to be ignored.


  • administrators

    You could also temporarily define your tool as having no heaters. For example, if you have M563 P0 D0 H1 in config.g, sending M563 P0 D0 will recreate that tool with no associated heater. That will also allow you to extrude without using M302.



  • Thanks Dave, I shall have a play later if only for future reference (I tested the rotation on one of the axis outputs)


  • Moderator

    @Garfield @dc42 I've updated this page https://duet3d.dozuki.com/Wiki/Test_axes_or_motors_individually to use G1 H2 movements. I've also added a section on testing extruder stepper motor movement. https://duet3d.dozuki.com/Wiki/Test_axes_or_motors_individually#Section_Testing_extruder_motor_movement

    Please could you check/comment for any errors/omissions.

    Ian


Log in to reply