Filament type assignment



  • Hi all,

    I would like to assign the same Filament to several extruders, but when clicking filament change it only shows the unused filaments. I don't see the point of defining 4 PLA filaments if they are all the same.
    Is that possible?

    Thanks ahead



  • @TC I don't / can't use that feature because my tools use multiple extruders. But as far as I can tell from here https://duet3d.dozuki.com/Wiki/Filaments, you have to load one filament into each tool then that loaded filament gets save into "/sys/filaments.csv". Maybe you could achieve what you want to do by editing that .csv file???



  • Yes that is my experience but I don't really get the point of not allowing to assign one type to more than one extruder.



  • @TC said in Filament type assignment:

    Yes that is my experience but I don't really get the point of not allowing to assign one type to more than one extruder.

    I believe it's something to do with how it's linked to load and unload macros but I haven't really delved into, because it's not something that I personally find very useful.



  • I found this out early on when attempting to utilize the filament configurations. My work-around was to create a baseline of a filament type then make a copy for each extruder (T0-PLA, T1-PLA). You almost need separate files as some commands require you to specify the tool/driver when loading. Unless there is something that I am missing that allows you to detect which tool it's loaded on. If one could detect the tool the macro was being loaded against you could utilize one file.



  • @Gamefanatic3D acually the "state.currentTool" expression from the object model is doing exactly that;-)
    So it would be very easy to have the option of Loading the same filament twice. Maybe @dc42 can have a look on that.



  • @TC said in Filament type assignment:

    "state.currentTool

    Thanks! I'll look into that. Actually I think after my update to 2.05.1 my filament config.g macros aren't even working. Going to check into that.


Log in to reply