Duet 2 Maestro No Ethernet



  • I have tried everything I can connect to the Duet 2 Maestro . But I can not get any activity on the Ethernet port.

    I know the router and cable is good I have tried it with other devices. I have used yat to turn the port on and off. I tried dhcp and static . I can not get any activity lights off the port at all

    Thank Yo


  • Moderator

    @mziminski Hi, sorry you're having problems with your Duet 2 Maestro. If you've followed the guide here https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7#s20 I can't particularly think of any other tests to run; the Ethernet module is quite 'dumb'!

    Could you post the YAT output when you turn on/off the Ethernet with M552 S1 P0.0.0.0 (which sets it to DHCP mode) and M552 P0?

    Other than that, it's probably a warranty replacement. Where did you buy it from, and when?

    Ian



  • Could be worth trying a fixed speed and duplex setting on router to rule out a compatibility issue as the Maestro doesn't fully support auto mdi/mdx negotiation.



  • i will post yat results when I am near the printer later. But i don't get any lights on the Ethernet port or the router showing it is connected. I have tried enable and disable the port but no lights at all. Almost like the port is disable through a jumper or is just bad.

    I have been pulling my hair our since mid december 😞


  • Moderator

    @mziminski Worth trying what @bearer said; check your router setup. Also if it forces large blocks/MTU, as RRF doesn't support that, though I'd expect to the LEDs to light up.

    @mziminski said in Duet 2 Maestro No Ethernet:

    I have been pulling my hair our since mid december

    Sorry for your hair! Next time save your follicles and ask here before you get mad!

    Ian



  • Could well be most consumer routers lack the settings to do such a test, so might be better to try with a direct connection to the computer and trying the settings on the computers adapter.


Log in to reply