Custom Shapeoko



  • Hello,
    I've purchased a shapeoko mechanical kit and a wifi duet controller from ooznest.
    I've loaded the firmware from ooznest, and instaled the limit switches and all "homes" well, but I'm struggeling to get it to "go to work XYZ" I get the following error:

    M98 P"workzero.g"
    Error: G0/G1: target position outside machine limits
    

    I'm not sure what to do 🙂

    this is my config.g file

    ; Configuration file for Duet
    ; executed by the firmware on start-up
    ; WorkBee Firmware Version 1.0.7
    
    ; Configure Connection - ENABLE ONLY ONE OF THE BELOW THREE
    M552 S1 ; Enable Wifi Network
    ;M552 S2 ; Enable Access Point Mode
    ;M552 S1 P192.168.2.14 ; Enable Ethernet - Change IP Address to suit
    
    ;	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
    
    ; DO NOT CHANGE ANY OF SETTINGS BELOW
    ; TO MAKE A CHANGE, COPY THE LINE OF CODE, PASTE IT INTO customconfig.g. THE CHANGE CAN THEN BE MADE IN customconfig.g
    ; ANY ADDITIONAL SETTINGS SHOULD BE PUT IN customconfig.g
    
    
    ; General preferences
    M453 ; Put the machine into CNC Modes
    M550 PWorkBee CNC Machine ; Set machine name
    G90 ; Set absolute coordinates
    
    
    ; Network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    
    
    ; Configure Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards                        
    M584 X0 Y1:3 Z2 ; Apply drive mapping to axes
    
    
    ; Configure Axes
    M92 X53.334 Y53.334 Z400 ; Set steps per mm
    M350 X16 Y16 Z16 I1 ; Configure microstepping
    M566 X500 Y500 Z500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X10000 Y10000 Z2500 ; Set maximum speeds (mm/min)
    M201 X150 Y150 Z150 ; Set accelerations (mm/s^2)
    M906 X2400 Y2400 Z2400 I100 ; Set motor currents (mA)
    
    
    ; Configure Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X800 Y1270 Z94 S0 ; Set axis maxima
    
    
    ; Configure Endstops
    M574 X2 Y2 Z2 S0 ; Set active low endstops
    
    
    ; Other Settings
    M140 H-1 ; Disable heated bed
    M564 S1 H1 ; Disable jog commands when not homed
    M911 S21.0 R23 P"G91 G1 Z3 F1000" ; Configure power loss resume
    M501 ; Load Stored Parameters 
    M98 Pcustomconfig.g ; Execute custom config settings
    

    this is my customconfig.g

    ; ADD ANY CUSTOM SETTINGS BELOW
    
    M552 S1 ; Enable Wifi Network
    
    
    ; General preferences
    M453 ; Put the machine into CNC Modes
    M550 P "Mega robot" ;
    G90 ; Set absolute coordinates
    
    ; Network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    
    ; Configure Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards                        
    M584 X0 Y1:3 Z2 ; Apply drive mapping to axes
    
    ; Configure Axes
    M92 X53.334 Y53.334 Z400 ; Set steps per mm
    M350 X16 Y16 Z16 I1 ; Configure microstepping
    M566 X500 Y500 Z500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X10000 Y10000 Z2500 ; Set maximum speeds (mm/min)
    M201 X150 Y150 Z150 ; Set accelerations (mm/s^2)
    M906 X2400 Y2400 Z2400 I100 ; Set motor currents (mA)
    
    
    ; Configure Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X800 Y1270 Z94 S0 ; Set axis maxima
    
    ; Configure Endstops
    M574 X2 Y2 Z2 S1 ; Set active low endstops
    
    ; Other Settings
    M140 H-1 ; Disable heated bed
    M564 S1 H1 ; Disable jog commands when not homed
    M911 S21.0 R23 P"G91 G1 Z3 F1000" ; Configure power loss resume
    M501 ; Load Stored Parameters 
    M98 Pcustomconfig.g ; Execute custom config settings
    
    M564 S1 H0 ; Disable jog commands when not homed
    

    and this is
    workzero.g

    ; workzero.g
    ; called GO TO WORK ZERO is pressed in WorkBee Control
    
    G1 H1 Z1500 F1500 ; raise the Z to the highest position
    G1 X0 Y0 F1500 ; go directly above the work zero position
    G1 Z0 F1500 ; go to the work Z zero position 
    

    someone please help, I'm a Javascript dev not a gcode dev yet 🙂



  • @vimes1984 said in Custom Shapeoko:

    Error: G0/G1: target position outside machine limits

    would suggest you're trying to do a move that is larger than the defined dimmensions for the machinem, which are set by

    ; Configure Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X800 Y1270 Z94 S0 ; Set axis maxima

    so

    G1 H1 Z1500 F1500 ; raise the Z to the highest position

    is outside of that, but i waa lead to believe the H1 parameter would take care of that for a homing move.

    on a side note you have this inside customconfig.g which calls itself?

    M98 Pcustomconfig.g ; Execute custom config settings



  • Hey bearer!
    thanks for the answer, so how would go about increasing the dimensions for the machine?
    alt text
    SO the "Home XYZ" works fine it's the "SET WORK XYZ" that gives me the error or if I try to lower the z so the spindle touches the work peice..



  • Huh, I was wondering if that could be the case, but as far as I know there wasn't any limitations preventing G1 H1 to work outside of homeall.g.

    In any case if the dimensions are wrong you change them in the lines that say M208 and set axis minima/maxima.

    I would for simplicity remove all duplicate lines from customconfig.g (if its in config.g its a already set, so unless you want to override it its redundant).



  • Here's what I ended up doinanyone is curious and needs to set up a workbee updgrade kit on a custom machine 🙂

    I edited the following files:
    homex.g
    homey.g
    homez.g
    homeall.g
    and the custom config file with the size of my machine...


Log in to reply