Error on home all



  • I have upgraded my duetwifi firmware to 3.01RC2 and I am getting the following error while doing a homeall. G28. It is a minor glitch as the printer still functions however it is a nuisance.
    If I do a home using individual axis homes there are no problems and no errors
    My homeall,g file is as follows:

    ;Home All
    G29 S2
    G28 xy
    G28 Z

    My homex.g:
    ; homex.g
    G91 ; relative mode
    G1 H2 Z10 F4800 ; raise head to avoid dragging nozzle over the bed
    G1 H1 X-665 F2000 ; move up to 240mm in the -X direction, stopping if the homing switch is triggered
    G1 X4 F600 ; move slowly 4mm in the +X direction
    G1 H1 X-10 ; move slowly 10mm in the -X direction, stopping at the homing switch
    G1 H2 Z-10 F200 ; lower the head again
    G90 ; back to absolute mode

    Homey.g:
    ; homey.g
    G91 ; relative mode
    G1 H2 Z10 F4800 ; raise head to avoid dragging nozzle over the bed
    G1 H1 y-350 F2000 ; move up to 240mm in the -X direction, stopping if the homing switch is triggered
    G1 y4 F600 ; move slowly 4mm in the +X direction
    G1 H1 y-10 ; move slowly 10mm in the -X direction, stopping at the homing switch
    G1 H2 Z-10 F200 ; lower the head again
    G90 ; back to absolute mode

    HomeZ.g:

    ; homez.g
    ; called to home the Z axis

    G91 ; relative mode
    G1 H2 Z5 F200 ; raise head 4mm to ensure it is above the Z probe trigger height
    G90 ; back to absolute mode
    G1 X50 Y60 F2400 ; put head over the centre of the bed, or wherever you want to probe
    G30 ; lower head, stop when probe triggered and set Z to trigger height

    deployprobe.g
    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Mon Dec 30 2019 23:59:11 GMT-0500 (Eastern Standard Time)
    M280 P0 S10 ; deploy BLTouch

    retractprobe.g:
    ;Retract Probe
    M280 P0 S90

    The error I receive:
    G28
    Error: Homing failed

    For reference this is my config
    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Mon Dec 30 2019 23:59:11 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Makerslide" ; set printer name
    M555 P2 ; Set output to look like Marlin

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes forwards
    M569 P6 S0 ; Drive 6 goes forwards
    M569 P7 S1 ; Drive 7 goes forwards
    M569 P8 S1 ; Drive 8 goes forwards
    M584 X1:2 Y0 Z3:4 E5 ; set drive mapping
    M350 X16 Y16 Z16 I1 ; configure microstepping with interpolation
    M92 X80 Y80 Z1600 E484 ; set steps per mm
    M566 X1100 Y1100 Z100 E1500 ; set maximum instantaneous speed changes (mm/min)
    M203 X4000.00 Y4000.00 Z800.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E2000 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1000 E1000 I50 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-40 Y0 Z0 S1 ; set axis minima
    M208 X560 Y290 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"!xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"!ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M558 P9 C"^zprobe.in" H5 R1 F200 T6000 A5 S0.02 ; RRF3 BLTouch connected to Z probe IN pin Probe type 9 (bl touch) singnal pin dive height is 5mm probe recovery time 1 f speed 200 travel speed between points 6000 maximum number of tries 5 tolerenc .02mm
    M950 S0 C"duex.pwm5" ; RRF3 Define BLTouch Servo (S0) on duet pwm1
    G31 P1 X50 Y0 Z2.05 ; set Z probe trigger value, offset and trigger height

    ;Thermisistors

    M308 S0 P"bedtemp" Y"thermistor" A"bed_1_heat" T100000 B3600 R4700 H0 L0 ;RRF3 Bed thermistor, connected to bedtemp on Duet2
    M308 S1 P"e0temp" Y"thermistor" A"Bed_2_heat" T100000 B3600 R4700 H0 L0
    M308 S2 P"duex.e2temp" Y"thermistor" A"Extruder 1" T100000 B4725 R4700 C7.06e-8 H0 L0 ;RRF3 duet3 e3d

    ;Heaters

    M950 H0 C"bedheat" T0 ;RRF3 define Bed heater is on bedheat
    M950 H1 C"e0heat" T1
    M950 H2 C"duex.e2heat" T2 ;RRF3 define Hotend heater is on e0heat

    M307 H0 A240.3 C608.7 D8.2 S1.00 V24.1 B0 ; Bed Heaters
    M307 H1 A240.3 C608.7 D8.2 S1.00 V24.1 B0 ; Bed Heaters
    M307 H2 A270.7 C90.4 D6.7 B0 S1.0 ;Heater 1 model

    M143 H0 S120
    M143 H1 S120
    M143 H2 S250

    M140 P0 H0 ; first bed heater is on heater 0 output
    M140 P1 H1 ; second bed heater is on heater 1 output

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H2 T45 ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H2 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q500 ; create fan 2 on pin fan1 and set its frequency
    M106 P2 S1 H2 T45 ; set fan 2 value. Thermostatic control is turned on
    M950 F3 C"duex.fan3" Q500
    M106 P3 S1 H2 T45

    ; Tools
    M563 P0 D0 H2 F0 S"Extruder_1" ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    ;M563 P1 H1 S"Bed 2"
    ;G10 P1 R0 S0

    ; Custom settings are not defined
    M501



  • could be because homeall calls xy before z; but x and y moves z.

    try reversing the order?



  • @percar said in Error on home all:

    ;Home All
    G29 S2
    G28 xy
    G28 Z

    The reason is, that for G29 the printer must be already homed. You should move G29 to the end.
    Standard for homeall.g is a combination of the code of homex homey and homez.
    That saves time for z-movement.



  • I should have mentioned that this is a Cartesian printer
    G29 S2 disables the height map which is what is required in order to home the machine
    If height map is still enabled then when z homes it will home to the compensated z position which will cause a positional error.



  • Just saw that G28 must be homed before using this command......missed it



  • @percar

    That would be the combined code for your case ....

    ; homeall.g
    G91 ; relative mode
    G1 H2 Z10 F4800 ; raise head to avoid dragging nozzle over the bed
    G1 H1 X-665 F2000 ; move up to 240mm in the -X direction, stopping if the homing switch is triggered
    G1 H1 y-350 F2000 ; move up to 240mm in the -Y direction, stopping if the homing switch is triggered
    G1 X4 y4 F600 ; move slowly 4mm in the +X and +y direction
    G1 H1 X-10 ; move slowly 10mm in the -X direction, stopping at the homing switch
    G1 H1 y-10 ; move slowly 10mm in the -Y direction, stopping at the homing switch
    G90 ; back to absolute mode
    G1 X50 Y60 F2400 ; put head over the centre of the bed, or wherever you want to probe
    G30 ; lower head, stop when probe triggered and set Z to trigger height


  • Moderator

    @percar said in Error on home all:

    G29 S2 disables the height map which is what is required in order to home the machine

    Try M561 instead

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M561_Set_Identity_Transform


Log in to reply