G10 Z don't work



  • Hello everyone, I am configuring the second extruder, I have entered the coordinates in both the Y and Z counters in the tool offsets (G10 P1 X0 Y25.5 Z0.5) but the displacement in Z is not calculated. I entered Z0.5 but it can be any value because it is motorized.
    I tried to search the forum for some similar posts but I found nothing. Anyone having the same problem?


  • administrators

    RRF does use the Z tool offset; however, after a tool change Z is not physically changed until the first movement after the tool change. If you want it to happen sooner, I think that should happen if you end your tpost#.g file with command G1 R2 Z0.



  • Hi @ DC42, I'll explain the problem better, when tool change from T0 (G10 P0 X0 Y-25.5 Z0) to T1 (G10 P1 X0 Y25.5 Z0.5) no Z offset is applied to the selected tool, while when returning at the main instrument (T0), the coordinate in Z is changed with an incremental value of 0.5 in negative. I, on the other hand, would expect that when I select T1 the coordinate in Z will be changed with an incremental positive value. It's correct?



  • What release are you running?

    I run a toolchanger with Z offsets for both T0 and T1 and they seem to be working properly.

    Board: Duet 3 MB6HC v0.6 or 1.0 (MB6HC)
    DSF Version: 1.2.4.0
    Firmware: RepRapFirmware for Duet 3 MB6HC 3.01-RC3 (2020-02-29b4)



  • @Danal, I am running on Duet wifi, RRF3.1-RC3, but in the past I had had the same problem with a previous version of the firmware, then I had set aside the configuration to fix another problem. I'm definitely doing something wrong. Could you kindly share the tool changer files to be inspired?


Log in to reply