Trouble with initial setup



  • New Duet WiFi arrived today - yippee. Having trouble already. I know it's something I've done wrong but not sure what.

    I followed the instructions under "Quick Start Guide" - "Getting connected". Got as far as point number 11 but instead of getting an IP address in the Pronteface window I get the following

    WiFi server starting up
    DuetWiFiServer version 1.02
    Flash size 4194304, free RAM 32856 bytes, WiFi Vcc 3.35V, host name: duetwifi, reset reason: Turned on by main processor
    WiFi is running as an access point with name DuetWiFi

    Any help you can give an old man would be much appreciated.

    Edit. And if I try to connect to 192.168.1.1. I get a singularly unhelpful message "unable to connect".


  • administrators

    That message means that the WiFi module is still running as an access point, because it failed to connect to your router using the password you gave it. Go back to step 8.

    In order to connect to 192.168.1.1, you may need to tell whatever device you are using not to connect to the internet in any other way, such as via a wired connection. Also, you may need to enter the full http://192.168.1.1 because some browsers (e.g. Chrome) will automatically try to use https.



  • Hi David,

    I'm trying that. It is showing up as an access point. So going back to step 8,;

    On my Nexus tablet using Firefox as a browser and entering http://192.168.1.1 I get "Firefox can't establish a connection to the server at 192.168.1.1. The site could be temporarily unavailable…...etc etc,

    On my Android smartphone I get "This site can't be reached http://192.168.1.1/ is unreachable."

    On my wifes's ageing laptop, I just get an unhelpful message that "windows is unable to connect"


  • administrators

    You did tell your smartphone/tablet/laptop to connect to the DuetWiFi access point instead of its usual one, and confirmed that it shows as connected, didn't you? If you do that then it normally doesn't matter what site you ask for.

    I've just turned off my router and started up one of my printers, and verified that I can configure my Android smartphone to use the Duet access point and then connect to http:/192.168.1.1. I'm using WiFi firmware 1.02, same as you.

    I guess it's possible that the WiFi firmware has been corrupted, but it seems unlikely.



  • Yes I did that. I've been trying all afternoon. I did once manage to get to stage 9 which gave me the list of networks but as soon as I entered the password, I got a message that it couldn't connect to server at 192.168.1.1. Now I can't seem to connect at all. I select "Duet WiFi" and "connect". My tablet will have 3 or 4 attempts then come up with "WiFi connection failure.

    EDIT. Ignore the above. What's happening is that the connection keeps dropping. I can only connect for a few seconds. So I connect to the Duet Wifi access point but by the time I get to entering the IP address, the connection has dropped. Then the tablet reverts to it's "normal" connection.



  • Update. Just watching the tablet, when I select Duet WiFi on the list of networks, and hit "connect" I get "connecting" for few seconds, then it reverts to "saved". This happens a few times, then I might get "Obtaining IP address.." for a while then it'll either just revert to connecting to my hub as normal, or I'll get a message to the effect that wifi connection failed before it reverts to the normal hub connection. About 1 out of 30 times it'll stay connected long enough to get the list of networks up and enter the password but after a reset, it still runs as an access point. The tablet is about 2 feet away from the Duet and the signal strength is fine.


  • administrators

    Is it possible that the tablet is ditching the DuetWifi network as soon as it realises it can't get into the internet through it?



  • @T3P3Tony:

    Is it possible that the tablet is ditching the DuetWifi network as soon as it realises it can't get into the internet through it?

    It's done that once or twice but more often than not, when it does connect I get a message to the effect that it is connected to a network but the network has no internet access. That usually manifests itself by the icon at the top of the screen having a exclamation mark next to it. That is the behaviour I would expect to see.

    At the moment, I can't connect at all. Duet Wifi is shown as an access point but neither my wife's laptop, nor my tablet nor both of our smartphones will connect. I just get various messages about failing to connect.

    I've had to walk away from it for now, otherwise I'll do something I might regret (like throw it against the wall or hit it with something large and heavy). I'll sleep on it (not literally) and try again tomorrow.



  • You may have to disable your home wifi signal. It's possible you have a setting such as "always connect to preferred networks if available" chosen, and so since there is no internet connectivity on the duet network, it immediately reverts to the known good network. I'm not sure if you've tried that yet, and sorry if you have, but it's worth a shot.


  • administrators

    Deckingman, it sounds to me that you have done all the right things. Perhaps the wifi module on your board is faulty. Try bot's suggestion, and if that doesn't work then I suggest T3P3 sends you another Duet WiFi.



  • Thanks for all the help guys and the good news is that today, it all works as it should - but goodness knows why it wouldn't yesterday.

    I switched everything off - PCs, phones, laptop, tablet, then reset the router. Fired it all back up and tried again. It all went smoothly like nothing had happened. Connected to the access point first time, without any hesitation or error messages, entered the wireless password, re started the Duet WiFi and it came back up with the IP address. Entered the IP address in my PCs browser and it came up with the web interface. Uncommented out the WiFi gcode from config.g from within the web interface, did a restart and it came straight back up. All just like it should be.

    I have no idea why it wouldn't work yesterday because I'd tried everything that I did today. I reckon there is an invisible Gremiln that follows me around and does things like that now and again just to p*** me off.

    Thanks again one and all for taking the time.

    Ian


  • administrators

    I'm glad it's working. I think it's threat of replacing the board that did it - I often find that threatening things with replacement gets them working again! Or maybe you had a lot of interference on 2.4GHz yesterday and your other WiFi devices are using 5GHz.



  • Yes I know what you mean about the threat of replacement - recently had that with some PC speakers that had been playing up for months but since I've bought some new ones, they've been fine (the new ones are still in their box). I think it's was case of "IT overload". You may actually be on to something with the interference on WiFi. I changed mobile phone providers this week and bought 3 new handsets at the same time (one for me for personal use, one for my wife for personal use and a rugged but basic one for me for work use). Those handsets have spent a lot of time updating firmware and apps and synchronising accounts etc. Also, BT finally got around to putting fibre in out street cabinet so I signed up for their superfast broadband a couple of weeks ago and got a shiny new hub. Maybe that's still settling down too - stranger things have been known to happen (at least in this house it seems).



  • Ian

    I have replaced my BT HomeHub I kept having all sorts of WiFi disconnect issues with it that I eventually got fed up with it and Bought a Netgear one which has been Rock solid.

    With the HH5 the wife couldn't use the Wifi for her works Laptop (A Panasonic Toughbook) and had to use a Cable since I swapped the Router those issues have disappeared May have something to do with it?

    But at least you have it sorted now?

    Doug



  • Hi Doug,

    Yes I know the BT HomeHubs don't have the best reputation but I've not had any other problems with "'er in doors" laptop or with our phones and my (rarely used) tablet. Everything else is wired and seems to be OK too. I've got the HH6 - don't know if that's any better than the HH5. I'll keep an eye on things though. What model Netgear did you get? Presumably it's an all in one VDSL Modem/Router?

    Ian



  • Ian yeah its the D6400 all in one absolute piece of pee to set up and supposedly does 300MBs on 2.4 and 1300 on 5 Ghz.

    Only thing with it And this shouldnt bother many people but there is no by Device Time locks if that makes sense Ie I would like to limit my Sons Ipad so it loses WiFi at say 9pm but can't without jumping thru quite a few hoops

    Doug

    ps I do know that the Home Hubs tend to change channels at will if they detect interference.



  • Hello to all,

    At first, 192.168.1.1 was created for specific manufacturers of routers, but has become the default for broadband internet modems throughout the world. For a big number of consumers this is best suited, because in case you are focused on the security of your own network system, you can easily change this particular IP.

    Using this specific IP address is generally safe, as it is immune to popular Internet threats. If a problem comes about, the IP address is well-documented, and it's easy to find a resolution.

    You can find more information here :

    https://www.quora.com/Why-cant-I-access-192-168-1-1-How-can-I-solve-this
    http://www.192168ll.net/

    Best wishes
    Elly


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.