WiFi reported error: no known networks found



  • Hello,

    Just got my Duet 2 wifi in the mail today and an error is coming up when trying to connect it to internet. The error says "WiFi reported error: no known networks found" adn on the next line says "WiFi module is idle". I'm using YAT and followed all instructions. Please help!!!



  • Here's what my terminal screen looks like when running the M122 command:

    WiFi module is idle
    WiFi reported error: no known networks found
    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-917DA-G4MSD-6JKF8-3S86K-K8UZA
    Used output buffers: 1 of 20 (9 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98840 of which 0 recycled
    Exception stack ram used: 256
    Never used ram: 6452
    Tasks: NETWORK(ready,1240) HEAT(blocked,948) MAIN(running,3740) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:20:57 ago, cause: power up
    Last software reset details not available
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 29.4, current 29.7, max 29.9
    Supply voltage: min 1.7, current 1.7, max 1.7, under voltage events: 0, over voltage events: 0, power good: no
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 2349484918
    Slowest loop: 0.23ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 0.18ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8

    • WiFi -
      Network state is changing mode
      WiFi module is idle
      Failed messages: pending 0, notready 0, noresp 6
      Failed to get WiFi status
      Socket states: 0 0 0 0 0 0 0 0
      ok
      Error retrieving WiFi status message: bad reply format version
      WiFi module is idle
      WiFi reported error: no known networks found
      WiFi module is idle

  • Moderator

    @garrett-good With that WiFi error, it looks like the WiFi firmware may be out of step with the main firmware. Though this, in itself, is pretty old too! I suggest you update to the latest RepRapFirmware 2 and update the WiFi firmware as well. See https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Fallback_procedure_Num_1

    I have to ask... is this a genuine Duet? We haven't shipped boards with v2.02(RTOS) of the firmware for a looooong time. Where did you buy it?

    Ian


Log in to reply