Need help tuning temperature



  • Hello! im workin on duetWifi configuratoin and stuch with temperature part. Firmware is 1.18

    below is my config related to temperature.

    During calibration M303 H1 S240 i have got error Error: Temperature reading fault on heater 1: temperature above limit
    and than reboots

    here is log

    0:49:38 Connection established!
    0:49:16 G10 P0 R-273.15 S-273.15
    M140 S-273.15
    0:49:02 Error: Temperature reading fault on heater 1: temperature above limit
    0:48:59 Auto tune phase 2, heater off
    0:48:27 Auto tune phase 1, heater on
    0:48:21 M303 H1 S240
    Auto tuning heater 1 using target temperature 240.0C and PWM 1.00 - do not leave printer unattended

    and config

    [[language]]
    M305 P0 T100000 B3950 R4700 H30 L0	
    M305 P1 T100000 B1800 R4700 H30 L0	
    
    

    Please help to fix temperature measurements.
    #1 fix hotend
    #2 is it possible to fix bed reading so, that cold printer shows the same temperature on the bed and hotend (now it is few degrees difference)

    many thanks!


  • administrators

    You can either use a target temperature lower than 240C in the M303 command, or you can use the M143 command to increase the temperature limit. If you don't already have a M143 command in config.g then the temperature limit will be 263C.



  • I think measurements are incorrect - i use chinese 100k sensor. It was working fine with arduino ramps board. heating to 210 degrees took a 2 minutes or so.

    when i try to calibrate it stops at 263, but real temperature is less than that. (less than 30 sec).

    is there a way to manually calibrate the thermistor?


  • administrators

    The B value of 1800 in your M305 P1 command is much lower than normal, which would explain why the temperature is over-reading. For most thermistors it is between 4000 and 4500.

    Do you have any data on the thermistor, or the temperature Vs resistance table that you were using before?

    You can calibrate it manually if you have a way of reading the hot end temperature accurately, such as a thermocouple probe inserted into the hot end, and a multimeter to measure the resistance. Or you can do it without the multimeter like this. Set the temperature limit much higher using M143 and set the temperature until you get a reading of around 230C on the thermocouple. Turn the heater off and send M305 P1 Bxxx commands with different values of xxx until the temperature reading you get matches the thermocouple reading.



  • Well, i changed B value to 4250. temperature does not jump but M303 gives error

    18:30:21 G10 P0 R-273.15 S-273.15
    M140 S-273.15
    18:30:02 Error: Temperature reading fault on heater 1: temperature above limit
    18:29:52 Auto tune phase 2, heater off
    18:28:33 Auto tune phase 1, heater on
    18:28:27 M303 H1 S240
    Auto tuning heater 1 using target temperature 240.0C and PWM 1.00 - do not leave printer unattended

    config lines

    M305 P0 T100000 B4250 R4700 H30 L0	
    M305 P1 T100000 B4250 R4700 H30 L0	
    [[language]]
    
    

  • administrators

    The default temperature limit is 262C and if you have a powerful hot end heater, it's not impossible that when the heater is turned off upon reaching 240C it overshoots to 262C. So you can either use the M143 command to increase the temperature limit, or use a lower target temperature in the M303 command.



  • many thanks for product and support!



  • David, thanks for input.
    With M303 H1 S200 it (at least) completed calibration.
    Log is below. However it says that temperature might reach as high as 855 🙂
    should i keep results or do some other calibration?

    what would you recommend?

    many thanks!

    [[language]]
    23:20:37 M500
    23:20:26 M307 H1
                   Heater 1 model: gain 835.7, time constant 208.1, dead time 17.0, max PWM 1.00, mode: PID
                   Computed PID parameters for setpoint change: P2.6, I0.013, D31.1
                   Computed PID parameters for load change: P2.6, I0.072, D31.1
    23:15:58 Warning: Heater 1 appears to be over-powered and a fire risk! If left on at full power, its                 
                   temperature is predicted to reach 855C.
                   Auto tune heater 1 completed in 283 sec
                   Use M307 H1 to see the result, or M500 to save the result in config-override.g
                   Heater 1 switched off
    23:12:46 Auto tune phase 3, peak temperature was 225.0
    23:12:26 Auto tune phase 2, heater off
    23:11:20 Auto tune phase 1, heater on
    23:11:14 M303 H1 S200
                   Auto tuning heater 1 using target temperature 200.0C and PWM 1.00 - do not leave printer unattended
    22:53:01  Connection established!
    
    

  • administrators

    Keep the results. A lot of users get that warning since E3D started supplying silicone socks with their hot ends.



  • ok, i want to share my hotend view and technology.

    how do you upload pictures here?



  • @dc42:

    Keep the results. A lot of users get that warning since E3D started supplying silicone socks with their hot ends.

    Any way to get that message to stop flooding the PanelDue Console?


  • administrators

    @Whitewolf:

    @dc42:

    Keep the results. A lot of users get that warning since E3D started supplying silicone socks with their hot ends.

    Any way to get that message to stop flooding the PanelDue Console?

    You should only get it once.



  • @dc42:

    @Whitewolf:

    @dc42:

    Keep the results. A lot of users get that warning since E3D started supplying silicone socks with their hot ends.

    Any way to get that message to stop flooding the PanelDue Console?

    You should only get it once.

    It seems to repost everytime a change to config.h is made that is why I was seeing it over and over again in the PanelDue console


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.