BLTouch not deploying RRF 3.0



  • Hello,
    I just installed genuine BLTouch V3.1 to my genuine Duet 2 WiFi board and when I went to test it I'm not able to get the pin to deploy using M401 or M280 P0 S10, nor the self test using M280 P0 S120. I'm not sure how to test which one is not working correctly or maybe you can spot something in the config.g file.

    Info:
    The pin deploys and retracts 2 times during power on and the red light is on. The cable between the Duet and BLTouch has been verified with an ohm meter. The white wire is connected to probe.in and black to ground. Red to +5V (pin 1) and brown to ground (pin 2) and orange to exp.heater3 (pin 8).
    I used RepRapFirmware Configuration Tool v2.1.8 and made changes according to the instructions online to config.g (shown below). RRF is V3.0

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.0 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-01-03b3
    Duet WiFi Server Version: 1.23
    Duet Web Control 2.0.4

    config.g (partial):

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S1 P"zstop" ; configure active-high endstop for low end on Z via pin zstop (Not using zprobe yet for end stop)

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable Heater 3 for use with BLTouch
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F120 T12000 ; set Z probe type to bltouch and the dive height +
    G31 P500 X-40 Y2 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:280 Y15:280 S20 ; define mesh grid

    The config-override.g does NOT contain M307 H3 line in it. And the deployprobe.g is M280 P0 S10 and the retractprobe.g is M280 P0 S90.
    I'm just trying to get it to deploy the pin before working on mesh leveling. I've even tried adjusted the Allen screw in the BLTouch, according to the manual, I've put it back to where it was. I don't have an oscilloscope yet. Not sure how I can test if it's the Duet or BLTouch is not working unless it's something in my config.g file.

    Thanks


  • administrators

    Your config looks OK to me and the wiring sounds correct. Please try firmware 3.01-RC3 because a lot has changed since 3.0.

    The M307 H3 command isn't needed, but shouldn't be doing any harm.



  • Thank you, I will give that a try.



  • I tried the latest RC and still didn't work. I also tried it with and without M307 H3.

    The only thing I could think of is putting the orange wire on ext.Heater8, in order to try and determine which is defective.

    What changes would I need to the config.g file to use Heater8 pin?

    Thanks


  • administrators

    @BeosDoc said in BLTouch not deploying RRF 3.0:

    What changes would I need to the config.g file to use Heater8 pin?

    Change exp.heater3 to exp.heater8.



  • @dc42 I meant Heater7.
    I changed M950 S0 C"exp.heater3" to M950 S0 C"exp.heater7"
    I moved the connection from pin 8 to pin 31 (heater7)

    It is now follows deploys, retracts and does the self test commands 😄

    Strange that it didn't work on pin 8. At least I don't have to buy anything else. Now onto finishing up.

    Thank you for your help and time.

    Out of Curiosity, why don't you use the Z_PROBE_MOD pin on the Wi-Fi version like you do on the Maestro?

    Thanks again
    Mitch


  • administrators

    @BeosDoc said in BLTouch not deploying RRF 3.0:

    Out of Curiosity, why don't you use the Z_PROBE_MOD pin on the Wi-Fi version like you do on the Maestro?

    We designed the Duet WiFi before BLTouch existed, and we didn't make the MOD pin PWM-capable.


Log in to reply