PL- 08N sensor and Duet 1.04



  • I have been trying to connect a PL- 08n proximity sensor to my duet to use it as a Z probe on a Voron. My printer has a 24 V power supply which I have used to power the sensor. However although the sensor triggers it then seems to latch on. I managed to find a reference to this problem elsewhere the solution being to reduce the input voltage to 5V. This seems to work for me also although I cannot see why especially as according to the data sheet the sensor needs a minimum of 6V. Has anyone managed to get this sensor to work with 24V?


  • administrators

    Need more information. How have you connected the sensor to the Duet, and how have you configured it in config.g?



  • Yes the sensor is connected to the Z - probe connector. The sense output to the in pin. I initially used 24 V from a fan pin to power the sensor. Although the sensor responded to metal it stayed on when I removed the metal I had used as a trigger. I subsequently replaced the 24v with 5v from the panel due connector and it seem to work OK. I haven’t tried homing it yet.

    The config line is

    M558 P5 I0 T18000 F1200 H30


  • administrators

    Check the Z probe reading, it should be 1000 when triggered and 0 when not triggered. You probably need to change i0 to i1 in your M558 command.



  • @pd said in PL- 08N sensor and Duet 1.04:

    I subsequently replaced the 24v with 5v

    Sensor isn't rated for 5v is it? Some are rated down to 6v and some of those work with 5v however not neccecarily reliable. As far as a quick google suggests yours is rated for 10-30v?

    (I've used them both at 5v and 24v, found them more reliable and having greater detection range with 24v. But they're probably not all created equal.)



  • @bearer @dc42 Thanks for your responses and apologies for the delay in coming back to you but the printer is a work in progress.

    @dc42 I did need to change the I0 to I1 but I had thought I'd already tried that with the 24V supply. Anyway its next on the list to try again!

    @bearer My sensor was supposed to go down to 6V but the probing is unreliable. When you used one did you connect the sensor directly to the board as I have done as its a v1.04.



  • Further update - changing to 24v causes the sensor to be triggered all the time. I will try 12V if I can find it on the due5 board



  • @pd said in PL- 08N sensor and Duet 1.04:

    When you used one did you connect the sensor directly to the board as I have done as its a v1.04.

    only used them as endstops, and npn version only briefly but yes, direct connection of signal to duet (and using duets internal pull ups).

    @pd said in PL- 08N sensor and Duet 1.04:

    Further update - changing to 24v causes the sensor to be triggered all the time. I will try 12V if I can find it on the due5 board

    sounds like sensor is bad tbh, or mislabeled at best.



  • but it does seem OK with 12V so I'll stick with that until the new one comes.


Log in to reply