Extrusion always starts with nozzle raised 1.45mm above glass bed?



  • For any print, extrusion starts with nozzle raised 1.45mm above glass bed?
    This is not caused by the print g code. I have to correct this every time with baby stepping.
    DuetWifi firmware 1.8.1 with dc42 IR sensor
    Bed levelling -Map looks good, almost all in the green
    Anyone have any ideas what might cause this?

    sample code:
    ; generated by Slic3r 1.2.9 on 2017-05-14 at 19:05:16
    M107
    G28 ; home all axes
    G1 X0 Y0 Z5 F8000 ; centre nozzle 5mm above bed
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M82 ; use absolute distances for extrusion
    G92 E0
    G1 E-6.50000 F2400.00000
    G92 E0
    G1 Z0.300 F6900.000
    G1 X0.000 Y13.676 F6900.000
    G1 E6.50000 F2400.00000
    G1 X-15.000 Y13.676 E7.28367 F1200.000
    G1 X-16.657 Y13.281 E7.37265
    G1 X-17.958 Y12.182 E7.46163





  • G31 Z0.672 P500
    I believe I'm already following all the guidelines to setting this value.
    But if, after all the calibrating and levelling, I go back and lower the nozzle until it grips the paper it then shows Z = -1.5/1.6mm instead of 0.1mm?



  • The Z value in G31 "tells" the machine how far the nozzle is away from the bed when the probe triggers. So, once you home the Z axis then do G1 Z0, the Z axis will move 0.672mm in your case and at that point, the nozzle should be just touching the bed. If the nozzle is 1.5mm above the bed, then the Z value is incorrect which means that you haven't calibrated the probe correctly. If as you say the nozzle is 1.5mm above the bed when you do G1 Z0, then you'd need to increase the Z value in G31 from 0.672 to somewhere about 2.172.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.