M501: bad model parameters



  • I am getting "M501: bad model parameters" when I start up my duet. I read several places to put M501 to wards the end of my config which I did below. I cannot find anything online in regards to this error. Please help.

    My config below:

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu Mar 26 2020 13:59:38 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Duet 3" ; set printer name

    ; Drives
    M569 P0.0 S0 ; physical drive 0.0 goes backwards
    M569 P0.1 S1 ; physical drive 0.1 goes forwards
    M569 P0.3 S0 ; physical drive 0.3 goes backwards
    M569 P0.2 S0 ; physical drive 0.2 goes backwards
    M569 P0.4 S0 ; physical drive 0.4 goes backwards
    M584 X0.0 Y0.1 Z0.3 E0.2:0.4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E400.00:400.00 ; set steps per mm
    M566 X3000.00 Y3000.00 Z180.00 E120.00:180.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z6000.00 E30000.00:6000.00 ; set maximum speeds (mm/min)
    M201 X300.00 Y300.00 Z50.00 E500.00:50.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E800:1200 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X290 Y300 Z430 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"io1.in" ; configure active-high endstop for low end on X via pin io1.in
    M574 Y1 S1 P"io2.in" ; configure active-high endstop for low end on Y via pin io2.in
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"io7.out" ; create servo pin 0 for BLTouch
    M558 P9 C"io7.in" H25 F1500 T9000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z2.6 ; set Z probe trigger value, offset and trigger height
    M557 X15:265 Y20:270 S50 ; define mesh grid

    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 B4092 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out1" T0 ; create bed heater output on out1 and map it to sensor 0
    M143 H0 S60 ; set temperature limit for heater 0 to 60C
    M307 H0 B0 S0.50 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"temp1" Y"thermistor" T100000 B4092 ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out2" T1 ; create nozzle heater output on out2 and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"out4" Q500 ; create fan 0 on pin out4 and set its frequency
    M106 P0 S1 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"out8" Q500 ; create fan 1 on pin out8 and set its frequency
    M106 P1 S1 H-1 ; set fan 1 value. Thermostatic control is turned off
    M950 F2 C"out9" Q500 ; create fan 2 on pin out9 and set its frequency
    M106 P2 S1 H-1 ; set fan 2 value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X30 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings
    M584 X0.0 Y0.1 Z0.3:04 E0.2 ; set drive mapping
    M307 H0 A33.5 C106.9 D0.4 V12.2 B0 ; heated bed pid tune
    M307 H1 A340.0 C140.0 D5. V12.2 B0 ; heated bed pid tune
    M671 X-45:330 Y0:0 S10 ; leadscrews at left (connected to Z) and right (connected to E1) of X axis
    M501 ; Run config-override.g



  • @jdumoulin said in M501: bad model parameters:

    M501 ; Run config-override.g

    As you see, M501 runs config-override.g . So post your config-override.g here and maybe someone can help.


  • Moderator

    @jdumoulin Duet 3 with SBC? If you’ve tuned your heaters and saved with M500, it saves the heater tune M307 with empty parameters. Known bug, being fixed soon. Either that or you have no config_override.g file!

    Ian


Log in to reply