z-stop not triggering



  • Hi all,

    Newby here, I'm afraid. I've got a DuetWifi board for a core XY printer. The z-min stop for some reason is not triggering when I query it (x and y are fine).

    It is not the wiring or the switch as it is recognised by the software if connected to either x-min or y-min stops. Is there something wrong with the DuetWifi board? Do I need to re-map the input read by the software (i'm not using the max-endstops)? If so, how do I go about this?

    I use the 2.02 firmware version

    Thanks

    Plop


  • Moderator

    Can you post your config.g?

    When you click the switch by hand does it trigger the Z endstop LED on the board?



  • Just checked. The z-stop led comes on when the trigger is pressed, just like the x and y stop leds for their respective switches.

    config.g and homez.g attached

    config.gcode
    homez.gcode

    Thanks

    Plop


  • Moderator

    You're configured to use a Z Probe, not an endstop.

    Do you have a Z probe?

    homez
    G91              ; relative positioning
    G1 H2 Z5 F6000   ; lift Z relative to current position
    G90              ; absolute positioning
    G1 X15 Y15 F6000 ; go to first probe point
    G30              ; home Z by probing the bed
    
    config
    ; Endstops
    M574 X1 Y1 S0                                   ; set active low and disabled endstops
    M574 Z1 S2                                      ; set endstops controlled by probe
    
    ; Z-Probe
    M558 P1 H5 F120 T6000                           ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.5                             ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20                        ; define mesh grid
    


  • Ah - that makes sense! I do have a z-probe but I haven't got to the configuration point where that is anywhere near operational. I'll work on it. Thanks for your help! I'll learn (hopefully)


  • Moderator

    If you need to change your config to use a Zmin endstop you'd need to make the following changes to the sections I quoted above:

    homez
    G91              ; relative positioning
    G1 H1 Z-500 F6000   ; Move Z axis to endstop
    G1 Z3 ; back off endstop
    G1 H1 Z-500 F360 ; hit endstop again slowly
    G1 Z3 ; back off endstop
    
    config
    ; Endstops
    M574 X1 Y1 Z1 S0                                   ; set active low and disabled endstops
    

    You can leave the zprobe section as is, or add a ; to comment it out.


Log in to reply