Trouble with first layer height on T3P3 Kossel Mini



  • Greetings,

    I'm calibrating my new T3P3 R3 Kossel Mini with Duet WiFi. All is going well, but I can't seem to get a good first layer without having to use the Z-Babystepping. I'm always too low, and the nozzle is scraping the glass bed. It takes 3-5 taps of the Web UI button to get up to a decent starting height. This is currently using the standard supplied setup of aluminum bed, covered with black paper, covered with glass. I have smeared gluestick on the glass (not over the whole diameter, but only over the center part where I have been testing printing my 40x40x10mm open cube).

    I've just gone through the calibration steps again at: https://docs.google.com/document/d/1k_3IYuRaRNjBqNOff-AcdCPjyf0nLv5rsSWXWlQVxSw/pub
    (specifically, 1605.2-1605.3), combined with reviewing https://duet3d.com/wiki/Calibrating_a_delta_printer

    I did end up changing G31 fromG31 X0 Y0 Z0.245 P500to```
    G31 X0 Y0 Z0.44 P500

    I also notice that when I run the G32, M666 and M665 sequence 3 to 5 times, I get very good convergence which leads me to the following, which are now in config.g:
    

    M665 R103.890 L215.0 B85.0 H247.510 X-0.230 Y-0.215
    M666 X0.80 Y-0.57 Z-0.23

    When the G32 as part of the print job runs, I note that it doesn't seem to get very close the numbers I get when I run G32 5 times.
    
    For example after running G32 5 times I receive:
    

    G32 Calibrated 6 factors using 13 points, deviation before 0.045 after 0.043

    When I run it only once (as during the GCODE startup before I print) I receive:
    

    Calibrated 6 factors using 13 points, deviation before 0.158 after 0.088

    Any thoughts of what I might be doing wrong, or suggests of ways to get my first layer height to be at a good height without resorting to pressing baby-stepping buttons on each run?
    
    Thanks,
    
    John

  • administrators

    To get the nozzle to start higher, you need to reduce the G31 Z parameter, not increase it. But the figures you mentioned look too low anyway.

    Did you do the G31 calibration with the bed and hot end up to temperature?



  • @dc42:

    To get the nozzle to start higher, you need to reduce the G31 Z parameter, not increase it. But the figures you mentioned look too low anyway.

    Thanks - Apparently I was interpreting the data backwards, as I assumed .44 was going to be "further away" from the bed.

    @dc42:

    Did you do the G31 calibration with the bed and hot end up to temperature?

    The G32 calibration was done with the bed and hot end up to temperature. The testing with paper and the G30 S-1 to set G31 were NOT done heated. Perhaps I should try that. The Kossel Mini manual doesn't mention heating until just before the G32 calibration.

    Thank You,

    John



  • Should I re-set G31 Z height to 0 before doing the calibration?


  • administrators

    There is no need to do that.



  • I re-did the G31 calibrations with hot-end and bed heated. New G31 Z parameter is now 0.17, and on the first two test prints, the first layer height was excellent. Adhesion on glass is good, and bottom was appropriately smooth.

    Thank you for the guidance, David.

    John


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.